Starting to believe I have defective board hardware

I just got an AML905x-cc and I hate it.

I have been unable to boot anything but Armbian, but even that isn’t working right.
I have 4 different power supplies, all FULLY capable of powering the Raspberry pi 4 8gb, and 3b+ I have. stealing power is all I can do unfortunately, the 4 is running from emmc and 3 is headless.

I am writing the sd card using dd or the raspberry os tool.

once I boot into armbian, I am unable to shut down, reboot, AND ctrl+alt+del fails.
I can’t even get a second tty

I have a genuine A2 class 10 sd card
I have tried to boot by runing a PXE server
I have tried core, libre, rasberry pi os, ubuntu, and armbian

I am ready to throw this entire piece of $h!zness into the trash and ask for all my money back. I’ve wasted 2 days on this, and all the money I would have saved is now wasted time and lost income. genuine anger is what I am feeling. I wasted a pair of saturdays and what for… i am willing to entertain almost anything to fix it all I wanted to have happen was a gui. I can’t even get a reliable cli.

I dont have fan but do have an overkill heatsink with a little thermal vomit. I hate heatsinks. my phone doesn’t have a heatsink, why does this underpowered piece of recycled waste need one? the same OS doesn’t need a heatsink on the pi 4 or 3… again, why do I need one now???

the only thing that works reliably is the monitor. an elecrow 5"
I can’t get wireless dongle detected, it works on all the other computers.

something has to be wrong since everything but this board works everywhere else. I would like to be wrong. please help?

edit: more evidence it’s hardward on the board- disconnected everything and tried booting just SD card= drawing 1.7A!!!

  1. Check the voltage on your power supply. It could be overvolting because Raspberry Pi power supplies are notoriously bad. If it goes above 5.5V, a lot of peripherals start shutting down and you’re basically frying the board and every USB peripheral on it (out of spec). The only reason it doesn’t affect Pi 3 is because of how poorly it was designed and the huge voltage drop before it gets to the 5V rails on those boards.

  2. Your overkill heatsink could be shorting something. Remove everything and just keep the board and check the voltage/current. The board does not need a heatsink. Take a picture of your setup. Make sure it’s not on a conductive surface.

  3. What wireless dongle are you using? If it is an overvolt situation, a lot of USB dongles will just not work. Also did you run the updates?