Sweet Potato --- Multiple Images Fail to boot

First time Libre owner, historically an RPI owner, hoping to use the platform. I purchased a sweet potato and am simply attempting to just boot to a console and get remote access… So far (2 hours in) no dice. Can someone help me before I just return everything? Why don’t any of the images just work?

Per the instructions on most OS pages, I’m using the “arm64” image since SweetPotato appears to be a UEFI board

I’ve tried multiple images. Raspbian, Ubuntu

  • Raspbian 11
    – 2023-05-03-raspbian-bullseye-arm64-full+arm64.img.xz
    – MDADM No arrays found
  • Raspbian 12
    – 2023-10-10-raspbian-bookworm-arm64-full+arm64.img.xz
    – MDADM No arrays found
  • Ubuntu 22.04.03
    – Image: Ubuntu-22.04.3-preinstalled-desktop-arm64+arm64.img.xz
    – Issue: Problem reading SD Status Register

Look, Power usage and features seem great, however the end user experience is not so great. I’m happy to write up everything I learn and give back. That said, I expect an out of the box experience where I can flash a “known good” image and have it at least boot to a console. I’d really like to see a similar to RPI experience where I boot, I can install the recommended wifi, and have a remote and working system in a few minutes. Currently this is not something I can make work (and I’ve used linux for >15 years).

Please help!

What power supply and SD card are you using?

PNY 32GB and I’ll have to look at the PSU its whatever I pulled off of one of my RPIs. Would that cause this type of failure?

If it was pulled off a Pi 3 or higher, it should be fine. The PNY probably has corrupt blocks. Our images detects silent corruption that Pi software ignores leading to unstable systems.

It’s a 5v 3A charger. Based on the advertising that this is a simple replacement for an RPI, I walked in with the expectation that I can flash an image to a card and boot. While I appreciate detection of silent corruption, I’m going on 4-5 hours of simply attempting to get through the boot process. I’ve yet to spend any time on the actual problem I’m trying to solve. Is there any sort of quick start and image that effectively boots to success?

I should add… If I’m doing this wrong, please let me know. If the expectation is I should be booting from USB or eMCC… I’m just looking for a known “it will work” setup.
Thank you

Last follow up, first attempt from (old) USB flashed with bootable image worked fine. It appears that booting from micro SD card is not supported out of the box with the default images.

The SD card probably has faulty sectors. It’s PNY. See our SD card guide.