The following packages have unmet dependencies: linux-headers-lc-stable-arm64 :

Im getting the following error

The following packages have unmet dependencies:
linux-headers-lc-stable-arm64 : Depends: linux-headers-6.1.26-05272-g26c406245a2c but it is not installable

This is the image I downloaded from here. It stopped upgrading.
Im unsure how to fix this are the headers different on these images?

Please run the following:

sudo apt install linux-headers-lc-lts-arm64 linux-image-lc-lts-arm64
sudo apt remove linux-headers-lc-stable-arm64 linux-image-lc-stable-arm64

Ok Thanks that worked. This unit had been running off the net in a sales booth playing music for months. It had missed many updates and would not finish its updates. Perhaps it will also help someone else.