The La Frite(aml-s805x-ac) 512MB RAM cannot operate any OS

I have several La Frite with 512MB RAM, I am using eMMC 5.X as a storage/flash for image installation. I tried all the OS as supported from the download website. But none of the OS is able to operate the 512MB RAM SOC board. Please help me and let me know what the image is able to boot correctly on La Frite.
The latest try which I still have EFI_ENG_PROTOCOL unavailable and the boot failed.

When did you purchase the board and what firmware do you have on it?

Try to use the following file to flash the latest firmware:

The Raspbian images and Ubuntu base and server images should work fine. Ubuntu Desktop will not work well.

I’m not sure how to update the firmware to the board.
I purchased the board Dec 2nd. totally 10pc.
I tried the Raspbian 10.0 and 11 base OS. Both of them is stopped at the initial, keep displaying some number and said timeout. After 10 times, the system is no longer processing the boot at all.

Need a picture or log of the exact message you are seeing.

I tried this:
and this:
However, I still have no idea how to update the firmware for the La Frite. The command keep saying “command not found” for sudo pyamlboot/ aml-s805x-ac

And this is the pictures for the boot of OS
OS version: raspbian 10 base for aml-s805x-ac

You shouldn’t need to update the firmware as the shipping firmware on the boards is newer than those on that post. The firmware on those post pre-dates the current images and work for Linux prior to 5.6. When the board starts, what does it report the u-boot version as?

It is looks like GNU GRUB 2.0.4

u-boot version. Not GRUB. GRUB is from the image.

I don’t know how to check it, but I think it is the latest version of the U-Boot.

See our first post. Use that image and flash it on a USB drive. Then plug it into the board and it should flash to the latest firmware.

My 512MB RAM La Frite already installed the latest firmware and ubuntu 20.04.5. everything boot fine, but new I cannot login the service of the ubuntu OS. I tried several possible username and password, still no good luck, anyone can help?

Read the release notes on the download page.

I finally got it works. Two boards work now.
Needed to update firmware first, then do the image on eMMC, then boot the board. Absolutely, 512MB is not enough for desktop OS, but lite OS works.


1 Like

You might get away with Raspbian desktop but even that is going to be slow. Gnome requires a minimum of 2GB.

You can also try Weston but forget about launch a browser they have become RAM monsters.

You wish it where u-boot 2.0.4 because 2.1.0 has a USB problem.

Those are not valid u-boot versions…