Trouble cloning SD card running Raspbian

Hello! I’m having a bit of trouble cloning an SD card in such a way that I can share it to allow others to get my exact set-up on their devices.

In short, I have a working install of Raspbian, on my AML-S905X-CC with some software pre-installed and configured. I want to clone this SD card to an image on my main Linux PC.

  1. I inserted the 16GB SD card into my PC, and clone it with dd like so: sudo dd bs=4M if=/dev/sdc of=base.img conv=fsync
  2. I took the resulting file (base.img), and flashed it to another SD card (This time 128GB). GNOME disks showed the exact same partition structure as the original SD card, as expected. Since this SD card was larger, there was trailing free space.
  3. When I inserted the new SD card into the AML-S905X-CC, both blue and red lights illuminated as expected, followed shortly by the green light illuminating. However, the boot process seemed to hang there, and there was no display output or network connection.

I’ve repeated this process with multiple SD cards, and made multiple attempts at cloning the original SD card using using GNOME Disks, dd, and GParted on a bootable flash drive. I’ve also tried flashing to the new SD card using dd, GNOME Disks, and Balena Etcher, all with no success. I always see the appropriate partition structure and files, but the device fails to boot after the green light comes on.

Just to clarify, the original SD card still boots fine. I just can’t find any solution that allows me to clone the working SD card to another SD card.

Is there something I’m missing? Thanks for the help.

I’m having the same trouble with both sd and eMMC. I feel like I’m missing something.

Do you get any messages? Cloned SD cards will boot on another device (same model) provided that the clone is bit for bit. That is how we are able to distribute images.

Disable automount on your system and use Win32DiskImager or dd.

I used dd, it was a few weeks ago, so I don’t recall if there were messages. I’ll try it again tonight, and I’ll see if anything pops out.

Admittedly, I didn’t try too hard before, since I was just trying out of curiosity. It didn’t boot after a few tries, and I said “Well, good thing I don’t need to do this right now.”

Just tried again last night. I fell asleep during the last flash and woke up to a fully functioning cloned sd card. I’m not sure what I did wrong last tme, but this time it worked perfectly.

I recall last time I used some options as per the guide I followed. This time I just did dd if=‘/dev/sdb’ of=‘/home/angus/filename.img’

Are there any options we should be using?

You should ensure the block size you are using is 1MB for faster dumping and flashing. Writing GBs of 512B sectors will destroy MicroSD cards pretty fast.