Trouble getting sound through HDMI on H3 Allwinner with Batocera


I am trying to turn a recently purchased Tritium H3 Allwinner board into a retro gaming station.

I have used the Raspberry pi installer to load Batocera onto the SD card, but after loading, it emulates fine, but there is no sound anywhere.

I am using the recomended power supply and have connected the board via HDMI to a TV monitor, which functions just fine getting sound from my labtop.

I have tried just about every combo of Audio Profile/Audio OutPut but only the options for Audio Profile which seem to register any response (they show a volume box which quickly disappears) are:


after exiting the settings menu after changing to one of these audio profiles, and a random audio output, and returning it sometimes defaults to something like:


Any tips for debugging this? Its not clear to me what the problem is.

Are you using the latest version of Batocera? I had all sorts of trouble getting v38 to work properly with my Tritium, but I have an H5. I had to use an older version but I forget which one exactly, it was either v32 or v34. I have both of them downloaded but I don’t know which one worked best and I don’t have it set up right now to check. I’m guessing v32, since v34 is the previous version that’s available and I tried that first. There’s also a v33 but I skipped that one for some reason.

I had some issues with video and sound, but I also forget which version did what. I don’t know if this will help since the boards are very similar but not exactly the same, but it’s worth a shot.

i used the latest version from the website, but it seems it was for the H5, specifically, although i am not sure if the difference between the H5 and H3 is great enough for that to matter. I did not see a " Tritium H3" specific batocera version, but i did find an ‘orange pi / allwinner H3’ on this page:

the ‘allwinner’ page Index of /batocera/cha/stable/
lists a few older versions

Now, i am trying the install for ‘Capcom Home Arcade’ V.34. After taking the SD card out, formatting it, and install Batocera V34 the device no longer boots. I will continue to trouble shoot later, using different installs. (I am not a clever man nor am i skilled in the ways of SBC science)

HDMI audio for H3 and H5 are not fully upstream. They require out of tree patches per Linux mainlining effort -

We recommend for you to post on the batocera forum and link back to this thread in case the patches are not in the batocera Linux tree.

1 Like