Troubleshooting General Boot Issues

I’m guessing you mean that it needs a powered usb hub in between the drive and the board. Will try out and post here on the results.

MicroUSB can deliver enough power for the board and some small peripherals. It’s not designed to power external drives and other high power devices.

Mine is external drive with its own power supply. Will it still not work?

If it is externally powered, it will work.

I recently purchased two ROC-RK3328-CC boards (to experiment with clustered computing) and I have been struggling with the “red & green solid lights” and not being able to boot.

I finally got it working a few minutes ago and wanted to contribute. :slight_smile:

I am using the following SD card: PNY 128GB Premier-X Class 10 U3 V30 microSDXC Flash Memory Card - 100MB/s, Class 10, U3, V30, A1, 4K UHD, Full HD, UHS-I, micro SD.

Couple things… I am running Ubuntu 22.04.1 LTS on my laptop. I used a “Uni” adapter (one end USB 3, the other end, USB C, and you can insert the Micro SD card in the middle) to format the Micro SD card. I used the ‘Disks’ OS utility to format the Micro SD card.

I installed the ROC-RK3328-CC-Debian9-Arch64_20180525.img OS image on the Micro SD card, using the recommended Etcher utility (‘balenaEtcher-1.13.1-x64.AppImage’).

For power, I’m using my Pixel 6 Google 30W USB-C charger and a new USB C to Micro USB cable. At first I thought the board may not have been getting enough power but I got past that with a pretty basic phone AC adapter.

My green light went away after boot (no “heart beat”), red light was solid, and I was pleasantly surprised with the Debian desktop when I plugged the HDMI cable into my monitor.

I believe my issue was simply related to the formatting and partitioning of the Micro SD card.

Hope this helps someone else. Thanks.

You can use the standard Ubuntu or Raspbian images. Currently upstream u-boot doesn’t support HDMI but it will soon. So it just takes about 30 seconds before you get video on ROC-RK3328-CC Renegade.

Sounds good. Thank you!

Hi, this is basically the same email I sent to on 06JAN2023 (there was no reply)

I received my SBC Renegade late last month (Brazilian postal service was slow) and have only now been able to start using it

I am running into a problem in getting the Renegade to work: it seems that it does not boot - I have:

  • flashed 3 different SanDisk Ultra microSD UHS-I cards with 3 different firmwares using 3 different Flashing tools (following your site’s instructions)

  • used 3 different power supplies (including a 5v/18A PC power supply – voltage between GPIO pins 1 and 6 is around 5.10v)

  • attached 3 different HDMI monitors (these all worked for Raspberry Pi’s 1 and 3)

-connected a 3.3v CH340 USB serial adapter to GPIO pins 34,36,38 (using PuTTY on Windows, 1,500,000 / 8 / 1 / No Parity / No Flow)

The results are always the same:

  • both red and green LEDs light (solidly, do not blink)

  • no video signal whatsoever (all 3 monitors)

  • no activity at all on the DEBUG GPIO USB serial adapter

  • power consumption is always around 200 mA (no change)

Also, all above (MicroSD cards, flashing tools, power supplies, HDMI monitors all work with Raspberry Pies 1 and 3)

So, I am wondering if I received a bad board or something else

Can you please let me know if there is a way to test the board (test routine / jumper combination / ???) before calling it a brick and requesting a replacement board?

Please let me know what are the next steps that I should take

Thank you for your kind attention and help

Sincerely, John Svendsen

Most likely you did not flash the image correctly or flash the correct image on your MicroSD card.

From all what I’ve read throughout the posts about booting issues, it is my undestandng that the green led blinks when the microsd card is being accessed - or have I missunderstood the green led’s behaviour?

The green LED is a programmable LED. It can be attached to any function.

I’ve been trying to run an update on a freshly imaged SD card. I’ve had this le potato board for about a week, and have tried the ubuntu, raspbian, and armbian images for the AML-S905x-cc board, and keep getting to this same point where I’m stuck.

I’m using a brand new SanDisk 32 gig SD card. Brand new 3 amp power supply.

When I run “sudo apt update” I end up with this same error:

Reading package lists… Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/deb.debian.org_debian_dists_bullseye_main_binary-arm64_Packages
E: The package lists or status file could not be parsed or opened.

I have tried removing the /var/lib/apt/lists/* folder contents as indicated on several raspbian forums. Once I get this, the packages file is hosed, and I can’t do anything but try a sudo apt autoclean, or start nuking the package lists and trying again. I’ve reflashed the OS on the SD cards about a dozen times, and this is my third power supply.

I’m still learning about the linux environment, but I think maybe this package is the main problem? Anyone else getting this, or know a way around this? I’d just like to update my system to the newest packages without bricking the entire apt system.

Are you getting the same error on Ubuntu and Raspbian?

When you get these errors, run sudo dmesg and copy the output.

It turns out this all seems to have been caused by some intermittent internet connectivity issues. I ran these commands and they completed successfully.

sudo rm -r /var/lib/apt/lists/*
sudo apt-get clean && sudo apt-get update

When I initially plug in my roc-rk3328-cc I get a green and red solid light. Nothing ever changes. If I unplug and replug power to the device then after 30s it boots fine. I’m using an SD card on ubuntu 22.04 image from your distro downloads. I have a 2A power supply. There’s no HDMI output during the solid green/red lights. If I have a ethernet cable connected I will see the NIC activity light shortly after re-powering the board (and then it successfully boots) but no activity on the first boot attempt. if I do a shutdown (shutdown -h now) and leave the board plugged into the adapter then wait a few minutes then I can’t boot it on the first try. If I immediately disconnect and reconnect the power after software shutdown then it works fine. I saw this behavior with both the ubuntu base and server images on my board.

What’s going on during the failed boot?

I’m going to assume I should return this board and try another absent any other info on the board only booting after plugging it in for some period of time and then re-plugging it.

This board is more picky about MicroSD card than other boards. Sometimes when the MicroSD card does not initialize fast enough, the first stage bootloader is unable to load the second stage.

Trying to boot from MMC1
mmc_load_image_raw_sector: mmc block read error

What MicroSD card are you using?

Ah okay, that’s interesting. I have a Sandisk Extreme 128Gb. Are there known issues on particular brand/models?

Any additional info here on preferred/known good cards?

I’ve been experiencing booting issues when trying to use Ubuntu and the Raspbian loads. My power supply is rated for 2 amps I use a short USB power cord and I’ve tried to use either WindDisk Imager and Raspberry imager. I can see that the Red and Green LEDs going on and then I can see on my monitors screen the loading of files. However when it reaches modem manager the screen goes blank and the Blue LED continually flashes at about a 1 Hz rate. I’ve gone so far as to remove all USB peripherals to reduce the possibility of power issues but that had not solved it. I’m using the suggested Sandisk Extreme memory cards my board fails to boot on more than one of them.
I’m able to use Armbian with out any issues at all, it just comes up without any issues. It comes up with both the Ultra and Extreme Sandisk cards with or without peripherals attached. So it appears to me that power is good and loading of memory cards is good also. The fact that my display is also working properly says that at least with Armbian I’m having no issues with peripherals I’ve chosen to use with my 905 board.
I had thought that maybe the loading software was causing issues so I made copies of my Astroberry images which I then was able to use without issues with the RBPi3. That along with successful use of Armbian at least says that the image loading programs are working.
Attached is a screen shot of the last entries of the booting I can see before the screen goes blank.
Sorry for tagging on to the conversation as I’m not used to using forums like this.