Ubuntu 22.04.1 Jammy LTS Server Release Notes

Thank you.

Just wanted to know if it was an insane thing to try but seems it’s worth experimenting with.

Question: How do I change the hostname if I flashed the image onto an eMMC module? → Where does the user-data file live? and can I edit it from the CLI? or do I have to mount the eMMC drive to another computer and edit the file from there? if so, how do I mount the eMMC module?

Apologies if the response is very basic. I am just not sure.

Edit: I installed ubuntu-22.04.1-preinstalled-server-arm64+roc-rk3328-cc.img.xz on the eMMC 5.x Module and I used these steps Libre Computer AML-S905X-CC eMMC Flashing Steps from Linux to flash the module.

If you boot from SD card and then flash the eMMC from the SD card OS, you can mount the EFI partition on the eMMC via:

sudo mkdir /mnt/mmcblk0p1
sudo mount /dev/mmcblk0p1 /mnt/mmcblk0p1

The user-data will be in /mnt/mmcblk0p1.

How do I enable autologin for ubuntu server?

This is standard Ubuntu question and not specific to our boards. Google the version of Ubuntu with the prompt you need. By default, getty processes are started to handle the login prompt. You need to add parameters to the getty command to skip the login prompt.

Hello friends, I want to connect the following dongle but it is not possible, it is necessary to buy the one that you offer or what can I do to connect it to your board.


thanks in advance

Hello, I grabbed your most recent image for my board [ubuntu-22.04.2-preinstalled-base-arm64+all-h3-cc-h5.img.xz] but the ubuntu/ubuntu login didnt work, has this changed?

Base is not server. You’re using the wrong credentials.

Thank you, I don’t know how I missed that.

I’m having trouble to putting networking to run.

I have installed ubuntu server on my S905X.

I logged in and followed the “Configuring Network Settings such as WiFi or Wireless” section of this documentation.

The problem is that neither Ethernet nor WiFi is working.

This is my /etc/netplan/50-cloud-init.yaml:

            dhcp4: true
            optional: true
            optional: true
                "MY - WIFI - NAME - (IT HAS WHITE SPACES ON THE NAME)":
                    password: "my_wifi_password"
            dhcp4: true
    version: 2

After editing the /etc/netplan/50-cloud-init.yaml, I runned sudo netplan apply and then a reboot.

It didin’t worked.

As soon as a log in again and run a curl ifconfig.me or a ping nothing happens.
From ping I get ping: connect: Network is unreachable.

If I run networkctl this is the output:

IDX LINK         TYPE     OPERATIONAL         SETUP    
  1 lo           loopback     carrier              unmanaged
  2 eth0         ether   no-carrier          configuring
  3 wlxa047d7105ee0    wlan    no-carrier      configuring

It gets stuck in configuring forever…

I have ethernet plugged in and my WiFi dongle on USB port.

Here is the output of iw dev:

    Interface wlxa047d7105ee0
    if index 3
    wdev 0x1
    addr so:me:mac:ad:dr:es:s0
    type managed
    txpower 20.00 dBm

I also tried to create the file /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the content network: {config: disabled}, rebooted and I still not able to use neither eth0 nor WiFi.

Do you have any suggestion?

netplan is a configuration renderer. It setups the configs for the actual network manager to use and connect. You need to check the logs of the network manager to see what is wrong with the connection attempt to the wireless network.