Ubuntu 22.04 Jammy LTS for Libre Computer Boards

The baud rate is correct. I use this command “minicom -b 1500000 -D /dev/tty.usbserial-110” and disable the flow control with the PL2303TA.

Do you have the ground cable connected properly? Please upload a photo of the connection.

This is my setup.

That is correct. Can you provide a screenshot of the command and output on serial?

this is the output

Everything looks correct. We have the same setup in our lab with PL2303TA and it works fine. We’re not using Mac though. Try it on another computer.

thank you anyway, I will try with another os

Unfortunately, MacOS doesn’t support 1,500,000 baud rate, it worked on linux.

1 Like

all the links to download ubuntu images are not working just show HTML code on the page.

all the links are broken to download the distros for Ubuntu all you get is HTML code .

It’s fixed now. Temporary service provider glitch.

Incorrect Checksums; ubuntu 22.04 image distro page:


At this location, it appears that at least the ROC-RK3328-CC image does not match the checksum listed. I have downloaded and extracted it twice and both SHA256 checksums were identical, but different from the checksum listed at the link, so the file seems to be downloading correctly (or there’s a systematic error in downloading, which I find unlikely).

Perhaps the Libre team could review the checksums file is accurate?

How to enable composite video on these images?

Just tried on a mac, the sha256sum is correct for me:

$ curl -L https://distro.libre.computer/ci/ubuntu/22.04/ubuntu-22.04.3-preinstalled-base-arm64%2Broc-rk3328-cc.img.xz |shasum -a 256

This matches the SHA256SUMS file

87808c3d7f88a3024ac1773388b0d7e588c9f7405fbf8c6c4dcccf1c635c0c81  ubuntu-22.04.3-preinstalled-base-arm64+roc-rk3328-cc.img.xz

The SHA256SUMS is for the .xz files, not for the extracted image, not clear from your post which one you are checking.

I downloaded the desktop version for all 64 and it boots into a command prompt asking me for the username/password, which neither works, (root/root or ubuntu/ubuntu)

I have downloaded 3 x and flashed 3x to a new card.

So something isn’t right.