Ubuntu image crashing on boot from SSD

I think I have followed all the instructions. I am able to get the roc-rk3328-cc to boot fine with Ubuntu using the SD card image. I want to boot from SSD but have hit a dead end with random issues getting the SSD to boot the Ubuntu image. It crashes at random places during the boot. Sometimes before the Ubuntu splash screen and sometimes during. I can see that if it crashes before the splash screen that it has the proper board name with a Bios from 4-1-2023.


  1. wiped Sd and SSD
  2. used the flash tool on SD card
  3. Downloaded the ubuntu server image from the distro site for the roc-rk3328-cc and extracted the image file
  4. burned the image on the SSD card using “sudo dd if=imagename.img of=/dev/sdX status=progress” sdx is the SSD. tried 2 different systems to burn
  5. Sd card in the board. SSD connected to USB3 port. Tried 2 brands of cables, 2 of drives and tried using powered usb hub. power supply for the board tried 2. both 2.5A. Red light solid all the time
  6. When powering on the board, I can eventually see where it initiates the system, sees the drive and starts the boot. Sometimes making it to the splash screen and other times not. Sometimes hangs on the splash screen and nothing more.

Drives Samsung 870 EVO 1TB and Crucial MX500 500GB
USB 3 to sata Sabrent and Startech
4-port usb 3 powered hub Sabrent

Any known issues with the December ubuntu 22.04.1 image and latest flashtool image for the roc-rk3328-cc?

It still sounds like it might be a power problem.

I assume you have a separate power supply plugged into the hub? I also assume you don’t have anything else plugged into the hub (just the one SSD)?

I looked for your hub on Amazon, the one I found comes with its own 2.5A power supply. The Amazon page also has this note:

“For a stable connection, the devices connected to the 4-Port USB 3.0 Hub must not exceed a combined current of 5 volts 900 mAh.”

I assume this is a typo and they mean 900mA, but who knows? I’m also surprised by this low limit if the hub is powered by a separate 2.5A supply, but again, who knows?

I looked up the Samsung SSD and looks like it draws up to 4W (this works out to 800mA at 5V), so it is close to the suggested 900mA limit. If you have anything else plugged into the hub you could easily exceed 900mA.

Thanks for looking. It is the only thing plugged into the powered hub.

Actually got one board to boot with the crucial ssd. I was ssh’ed in running sudo apt update and it dumped. Anybody able to point me in a direction?

reimaged the drive. First boot it hung here(pic attached). pulled plug. Second boot it hung on ubuntu splash screen.

Issues with Ubuntu, raspian and Debian images. All unstable and crashed. Looks like a firmware issue. Loaded the July 22 version (from the download site and looks like the one prior to 4/23 version) with the flash tool and Ubuntu is up and stable. How do I get the attention of someone to look at this issue?

Can confirm the issue this user is having. Attempted to boot Armbian, Raspbian, and Ubuntu Server on two different roc-rk3328-cc Libre Renegade boards running the recommended power supply (LoveRPi 5V 2.5A MicroUSB Power Supply with LED Indicator) both running on the May 25th 2023 firmware (https://boot.libre.computer/ci/roc-rk3328-cc). I am using a PNY 64GB Micro SD card as for the firmware/bootloader, and a Samsung 870 Evo 1TB SSD for the OS with a USB 3.1 to SATA Sabrent adapter plugged into a Sabrent USB 3.0 hub (model HB-UMP3) with a dedicated power adapter (for extra power support for the SSD) which is then plugged into the USB 3.0 port on the Renegade board.

On the May 25th 2023 firmware, both boards would get random freezes either during boot or just while using the system regularly, messages about seg faults when trying to run sudo apt update, and blocks of text on the screen containing memory addresses and messages about core dumps/abortions (similar to the ones in the images by the original poster).

I downgraded to the July 18th 2022 firmware on both boards (link below since I am limited to the number of links I can send since I’m a new user). Both boards are currently running the most recent Ubuntu Server image (link below). When I downgraded the firmware, on both boards the random freezes stopped, I was able to run sudo apt update and sudo apt upgrade all the way through no problem with no messages about seg faults, and upon booting, the blocks of text containing memory addresses and the messages about the core dumping/aborting stopped.

I highly suspect that this issue is a firmware issue in the May 25th 2023 version of the firmware, and not a power issue as speculated by another commenter. May someone from Libre please confirm this problem and/or look into what might be causing this? Thank you!

Edit: accidentally said May 2025 instead of May 2023

July 18th 2022 firmware as referenced by my previous comment - https://boot.libre.computer/manual/2022-07-18/roc-rk3328-cc

Ubuntu Server image as referenced by my previous comment -

We will be releasing a new version of ROC-RK3328-CC firmware in a week or so. Please try that when it is released as part of a broader software update cycle.