Vdd_arm: ramp_delay not set kernel messages on Renegade

Greetings Everyone,

This is my first post here, so bear with me. I recently purchased my ROC-RK3328-CC (Renegade) after giving the Libre Computer systems a try after finally giving up on getting another Pi for a reasonable price. After all of the negative things I read online, setting this little board up was a snap and I’ve now done 3 OS installs on it with no problems at all! Now, having said that, I have tried installing Ubuntu Preinstalled Base, Ubuntu Preinstalled Server (both 20.04) and Raspbian 11 from the Libre server and I am getting the message in the subject line, “vdd_arm: ramp_delay not set”, repeated several times about every 2 seconds or so. I am running the Ubuntu Server image at the moment, and I’ve done the usual apt-get update and upgrade and even updated the kernel and fwupdate, which were held back, yet the spamming kernel messages still persist. I googled this error and found nothing except similar references in the kernel code, which makes sense, but I don’t know how to resolve the problem. Since I’m not seeing anything with this specific error online I am just guessing this is a specific issue with this board (and maybe other Libre models?) and the kernel. Does anyone have any thoughts on this? I am running kernel 6.0.8-00789-g99a6460d70b3 which was fetched this morning.


Our kernel configs enable regulator debugging so the vdd_arm message shows up. Normally it is hidden. It’s just annoying log spam. We will evaluate how to fix it either with an device tree update or turning off regulator debugging if we think it is not important.

Great! Thank you for the explanation. I thought it was something along those lines but I wasn’t sure. The main reason I inquired is because that much spam prevents me from logging any kernel messages to my syslog servers which isn’t that big a deal, just need to remember to add ;kern.none to the remote logging line in 50-default.conf for any new units I deploy.

This has been fixed on the latest images. For existing images, we recommend using libretech-flash-tool to re-image the bootloader and the message should go away.

Many thanks! Not only did this change allow me to get logging setup up with the rest of my cluster, I also noticed that you changed things so the heartbeat is now on the green activity LED on the Renegade and the red one stays lit indicating power on like the army of Pi’s I have in the same rack. Makes checking things at a glance so easy! I just placed an order for my second unit and I am now planning to use this first pair to replace 2 Pi2’s I have in production. Thank you again!

Red is now always on except when the kernel panics. If the kernel panics, it will blink. Green is heartbeat now. We had this patch but it escaped the build due to an error.