VNC Server/Viewer setup

I have installed 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc on an AML-S905X-CC. I have enabled SSH and VNC. SSH works, I can access raspi-config through SSH. systemctl status vncserver-x11-serviced.service shows the service started and active. When I try to connect using VNC Viewer (viewer and server are RealVNC) I get “The connection was refused by the computer.”
I have a RPi2 and RPi3, both accessible via VNC.
Anyone have an idea on what to check/configure?

Bueller ?.. Bueller?

Use the search function.

I have.

Have a nice day.

RealVNC requires a license. Disable RealVNC and use TightVNC.

If RealVNC requires a license, why do I have no problem with RealVNC on my RPi 2 and 3(Buster and Bullseye)? Nevermind.

I’ll research tightvnc.

This is already covered. Use an open source solution like TightVNC that is better. Please use the search function.

“That is better” is subjective.
I have used the search function and it leads me to believe there is something in the design of the Le Potato that generates the problem,
Again, I don’t have these problems running Buster and Bullseye on a P2 and Pi 3.
I’ll look at something else.

RealVNC is non-free software licensed for Raspberry Pi. We do not support non-free software. Please purchase a Raspberry Pi 2 or Raspberry Pi 3 if that suits your needs better.

I did.
I’m also trying to get the Potato to work… for me.