What is the Largest Micro SD Card Size & Brand Known to Work for Le Potato?

Here is my situation:

I have tried 2 types of SD cards recommended by Lebre for the Le Potato .

  1. 64GB SanDisk Extreme
  2. 32GB Samsung Pro MicroSD cards .

My SanDisk Extreme 64GB fails to boot and I’ve tried multiple times to re-flash image to no avail.
My 32GB Samsung Pro succeeds every time no fails.

I am looking for hopefully if its possible and exists 1TB or greater micro SD card that will work for Le Potato. The largest I see available from Samsung Pro is 512GB.

Does anyone know of another working brand that meets these criteria’s and boots properly?

I haven’t had any issues booting from a 32GB Sandisk Ultra, though I’ve tried a few other larger capacity cards from sketchy brands with poor results.

I don’t have an answer for the limit on card size, but I will say you’re probably better off running your OS on the SD or eMMC and using a USB device for storage if you need a TB. Just avoid spinning hard drives, they can draw too much power for the tater.

I get MUCH better performance from the eMMC than SD cards of any kind, so I would definitely recommend that route if you’ve got the $20 or so to spare.

1 Like

I’ve had no problems using the MicroCenter branded microSD cards. I’m using a 64GB and it works fine. There may be issues using SDXC vs SDHC type cards, I don’t know. Just wanted to report Microcenter cards seem to work fine.

SanDisk Extreme is supported. Do you get any errors?

Interesting, I’ve booted and worked with a 64GB SanDisk Extreme just fine along with many others.

Does the same microSD card work with other devices/boards?

I gave the SanDisk a few attempts but haven’t tried since. I wasn’t able to get the Ubuntu image to boot or finish booting so I switched to Samsung. I will let you all know if I give it another go, thanks for all the help and recommendations.

I am getting both the SanDisk Extreme and Samsung Pro tomorrow in an attempt to fix my booting problems with the Le Potato (it boots and works perfectly with Armbian-based images, but none of the Libre-provided images of Ubuntu and Raspbian). Based on the errors when booting that look like a bunch of memory reading errors, I figured it was my micro sd card.

Provide the exact errors and we can tell you what it is.

For some reason I had issues verifying the image when writing using win32diskimage…I would get the error: “Verification failed at sector 2048”

I have successfully used Raspberry Pi Imager to write and verify the same ubuntu image (from the libre distro). I am doing more tests now to make sure it works, but so far the booting seems (kinda) okay. Initial boot causes the following error that then seems to resolve as it prompts me to login, going to the terminal after.
EFI stub: Booting Linux Kernel…
EFI stub: ERROR: FIRMWARE BUG: kernel image not aligned on 64k boundary
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services…

Just tested using the 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img image with my old microSD card with the raspberry pi imager which passed verification, however, it booted up and had a bunch of memory read errors. When I tested the same image using the sandisk extreme microSD, it booted and worked. It looks like the microSD was the culprit to my troubles these past few days.