Wifi freezes after short time

Hello, I have tested a tp-link Archer T3U usb3.0 AC1300 wifi dongle (2.5ghz + 5ghz) on both the ALL-H3-CC and AML-S805X-CC running the latest matching Raspbian distros downloaded from distro.libre.computer.

On both units, the wireless connects with no problems, but after a few minutes all communication freezes. I can’t ping, transfer, etc. Rebooting the unit fixes the problem. ifconfig down/up does NOT fix the problem, and when trying to ifconfig UP, it reports that the dongle is busy.

I have tested with two different power supplies, one rated at 5V @ 1A and the other rated at 5V @ 2A and the same issue occurs.

Is it just a problem with this dongle? I have ordered the recommended dongle from amazon (GenBasic) so we will see how that works.

So as of now, I can’t do an apt upgrade since it starts downloading then stops about 25% into the process and loses connection.

I have tried connecting to both 5GHz and 2GHz networks.

I have tried different USB ports.

Thanks for any pointers!

Try installing the linux-image-lc-lts-arm64 kernel which we are moving to instead of stable.

Where do I find this image? I don’t see any LC images in the distro.libre.computer repository.

sudo apt update && sudo apt install linux-image-lc-lts-arm64

I was never able to get the TP-link USB wifi to work without freezing. However, switching to the generic 2.4GHz wifi adapter from Amazon solved the problem: it runs stable.

Please update the kernel and check to see if it still happens.