2023-09-27 Libre Computer Images Update 2023-Q3 (Pre)


  • Remove dedicated images for UEFI ready boards
  • Introduce generic UEFI images for UEFI ready boards
  • Introduce updated Debian images

Board Specific

  • Introduce Cottonwood support
  • Introduce Wake-on-UART for Amlogic boards
  • Fix ROC-RK3399-PC PD and boot video output issues

Remember to update your firmware.

The early August and now late September bootloaders and images seem more stable than the previous. Issue I see on the roc-rk3328-cc on boot with usb storage is “scanning for usb storage” returns 0 devices. It will randomly identify the storage and boot but most times won’t. I’m not sure if this is a timing issue as usb storage devices (I’m specifically using SSD) initiate. Is there a way to add a slight delay before the usb/usb storage scan takes place allowing the devices to initiate if that is actually the problem?

Is this a regression? Some USB storage devices (SanDisk) are just poorly designed and not scannable occasionally no matter if you wait or reset the USB device. You have to do a full power cycle for them to work in u-boot.

I see the same issue with SSD boots on other devices googling the issue. Solutions I have found discuss delaying the boot allowing the SSD devices to power and fully startup before the scan starts. I have 2 different brands Samsung and Crucial. Seems if the board is holding any power, it boots faster than being turned off for a while and powered on. If I reboot or unplug wait a few seconds and plug back in it fails to boot. If I unplug for a while and come back later, once I plug back in it works. The failure also occurs with a powered usb hub. Seems a slightly longer delay in the boot is needed before storage scan.

Is there a boot delay in uboot to pause for an extra second while devices power up/initiate with the board?

Have you tried the latest bootloaders released last week? Does this still happen?

Just tried. The same issue is occurring. Just seems the firmware is scanning too quickly before the usb SSD initializes.

You can override the preboot environment variable at the u-boot prompt. It controls how and when USB is detected. You must have a FAT/EFI partition on your boot device to save the environment variables.

env set preboot "sleep 5; $preboot"
env save

Does that matter if the boot usb discovery finds 0 storage devices? Is it even getting to u-boot if 0 storage devices are found? I thought about u-boot interaction but isn’t that on the first partition of the SSD? Or is u-boot still the firmware?

The above assumes Tritium Le Potato or Renegade where the bootloader is from the MMC device. If you are using a board with onboard firmware, then all bets are off.

to clarify, It does not get to u-boot prompt. The latest firmware I am unable to get to boot at all. Will let sit overnight and see if I can tomorrow. I have attached where it fails.

Maybe I misunderstand and what you posted I can still do. I just assume that not getting to the boot prompt I’m not as far as u-boot on the first drive partition since it can’t find a storage device.

roc-rk3328-cc. PNY MMC

It is at boot prompt. You screen is cutting it off.

I don’t have another screen. Is there a keyboard sequence to stop the boot into prompt? Sorry to bug you about that.

Or can it be done by updating a boot partition file

It is at the prompt already as we stated already previously. When it does not detect any bootable devices, it drops to prompt.

when i do save env, it says environment to fat… No valid partition found.

My setup is boot sector on MMC and boot partition and ubuntu on SSD.

If it is because I an missing something off screen again, I will buy a new monitor tomorrow.

Please take the time to read our previous responses about needing a FAT partition. You should be able to control the aspect ratio of your TV on the TV remote.