Android for Libre Computer Boards

Various outdated versions of Android are available for our boards. Since Android depends on Vendor SDKs, they’re usually not supported or upgraded over time. We do not recommend using Android as the building block of anything. These images should be used for testing and experimentation only. There’s is little to no support for any issue you will have. The Android SDKs used to build the images are only provided under NDA by the SoC vendors and even then not supported very well if at all.


Hello Any insight on how to get the standard 3.5" lcd display(xpt2046) working with this img for the le potato?

You are on your own if you use Android. We do not support it outside of providing the basic image and SDK.

1 Like

NP Thank you for the quick reply.

So I see there is just standard android but is there a android TV that is flashable to the micro sd card slot?

We do not have the bandwidth to maintain Android. You can change the target and manifest to add Android TV components and build it yourself.

1 Like

How can I pull the boot files for the amlogic s905x

Just a follow up I just am checking to see if I somehow missed. your message?

See the instructions in the OP. Click SDK.

Oh okay I am super sorry! I am a newbie!

Android is a PITA. It takes forever to compile so development is not fun.


i am tryng to flash for LAFRITE S805x-ac the android 9 .img → AML-S805XAC-Android-P2021-07-01.emmc.img
i get an error :
le fichier source n’est pas une image disque valide. La taille du fichier (d’2941683496 octets) n’est pas un multiple de 512 octets.

how can i manage or find another .img ?

thank you

Please read the release notes. Indicate what tool you are using and what step the error occurs on.

i used raspiimager or window & for linux : same error message
gnome disk utility under Linux : no way to write on emmc

Read the release notes! That’s not how you do it.

Hi Libre Computer,

I flashed and booted the Android 9 image to my Le Potato. It gets to the set up screen but can’t detect any wifi to sign into google. Wifi usb dongle works with Armbian, Raspbian, Ubuntu. Please tell me what to do to make it work with Android.

Any help is much appreciated.

Thanks very much!

1 Like

Just posting here to say that connecting the ethernet cable was able to connect to the internet.

I downloaded android 9 to my Le Potato, everything worked, but Wi-Fi was not detected. How can I fix this?

Android does not support WiFi. It requires custom kernel integration that you have to build from the SDK.

How to program via EMMC? And where can I get the file (aml_upgrade_package.img) which is written in the Android EMMC programming instructions. Thank you.