Booted Ubuntu 22.04.3 base on AML-A331D-CC and cannot login

I start with the fact I’m confused with the forum structure, pinned posted with category explanations aren’t filled up.

I followed the guideline to flash the boot image first, then downloaded base Ubuntu 22.04.4 with +arm64 suffix (for UEFI boards). I tried to login, but ubuntu/ubuntu pair doesn’t work and with root/root and attempt to change password I get:

Ubuntu 22.04.3 LTS arm64 ttyAML0

arm64 login: root
You are required to change your password immediately (administrator enforced).
Changing password for root.
Current password: 

Authentication token manipulation error

Ubuntu 22.04.3 LTS arm64 ttyAML0

arm64 login:

What’s wrong with the image?

Did you use a bit accurate flashing tool? When I was flashing with balenaEtcher, I had similar login problem with Debian 12.

All other boards I used to date (multiple Raspberry Pis, Orange Pi 3B, Banana Pi M2S) worked with the same method - Disk Image Restore of Ubuntu.

Why that bit accuracy is so important for these boards? Is something skewed in a way how partitioning is handled?

I’ll try using dd to repeat the surgery.

Read the prompts carefully. It prompts for the password a third time after verifying the initial password. There’s nothing wrong with the image.