Booting from External USB Device or BootROM Unsupported Device

Thanks for the fast reply!

I just bought the AML-S905X-CC for HomeAssistant. First problem was that, HA OS will not boot on this board. Is there any tricks to get HA OS to boot on Le Potato? This would solve all problems at once.

Other problems I’ve encountered:
-I’ve been debugging HA Supervised install now for 10 hours and I can’t get it to work on “libre-computer-aml-s905x-cc-debian-stretch-headless-mali-4.19.55” image (“Preparing Home Assistant” gets stuck on “[supervisor.plugins.base] Watchdog found audio plugin failed, restarting” and error [supervisor.utils.dbus] D-Bus method org.freedesktop.DBus.Properties.call_get_all not exists!".

-I also tried to install KVM and VirtualBox to run HA OS in VM. But CPU doesn’t support KVM and atleast “ubuntu-22.04.1-preinstalled-desktop-arm64+aml-s905x-cc” image can’t install VirtualBox.

The image you are using is obsolete and 3+ years old. It will be replaced soon. I recommend starting off with Ubuntu or Raspbian from our site. That’s why you’re probably spending a ton of time and not having anything work.

I also tried to install KVM and VirtualBox to run HA OS in VM. But CPU doesn’t support KVM and atleast “ubuntu-22.04.1-preinstalled-desktop-arm64+aml-s905x-cc” image can’t install VirtualBox.

HomeAssistant and Klipper are two OSes on our todo list. KVM should work on Ubuntu 22.04.1 and 20.04.5 images. If it doesn’t work, send us the logs and we will fix it.

1 Like

What is the timetable with that HA in your todo list? Weeks or months?

KVM did work on raspbian, but CPU does not support virtualization:
“egrep -c ‘(vmx|svm)’ /proc/cpuinfo” outputs “0”. Quoting: " As long as it doesn’t return 0 , then you’re good" from HomeAssistant Community.

Next I will try to install Debian 11 with your instructions (Debian11/Debian12) and try HA supervised installation again (HA Supervised).

  1. Depending on the complexity. We have a lot of engineering tasks mostly to support commercial customers. It could be weeks or months. Currently a lot of users have gotten those things to work by just following standard Ubuntu instructions.

  2. vmx and svm are x86 virtualization flags. They do not apply to ARM devices. Our kernel has virtualization enabled.

  3. Recommend trying with Ubuntu as Debian install is cumbersome right now. We will have Debian images released in weeks.

1 Like

Thank you for all the help. Got HA Supervised working with ubuntu server 22.04 LTS image from USB. :partying_face:

1 Like

Kindly share a guide when you have the time on your process. It may help others.

1 Like
  1. SD-card boot image from LibreComputer (link above)
  • Not necessary, but enables USB SSD.
  1. Image: Ubuntu server 22.04 LTS (
  • Unzip: tar -xf
  • Flash: I used balenaEtcher to flash USB stick.
  • User and pw: ubuntu
  • update+upgrade ofcourse.
  • install jq ca-certificates curl gnupg lsb-release
  • apt --fix-broken install (some dependencies will be missing)
  • reboot
  1. Home Assistant Supervised
  • Follow this instruction (link)
  • OBS! For Docker install, follow their instructions: docs docker com/engine/install/ubuntu/ (add dots, new users can’t add more than 2 links)
  1. Configurating HA Supervised
  • Choose Raspberrypi4-64
  • Wait 5-10 minutes and you should see HomeAssistant preparing page in port 8123

That should be all. Enjoy!

1 Like

I have HA running on a rk3328. Should also work on other Libre boards. I installed Libre Raspian Bullseye lite on the rk3328. Then followed the HA supervised install guide here. GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

Thanks for the great guide! However, you should post this as a new thread title so that people can find it. eg. “How to install HomeAssistant Supervised on USB”

I successfully used these instructions to copy an existing microsd to an SSD (with SATA to USB) and then boot from the SSD from there on out. This method requires a dedicated, empty, microsd card that just has the bootloader applied from the libretech-flash-tool. Before you swap the microsd you need to copy the data from your existing, working microsd to the SSD. On a linux machine that has both drives connected, do the following:

sudo su
cat /dev/mmcblk1 > /dev/sdc

The mmcblk1 is the source microsd (your device name may differ) and the destination SSD is sdc (same). This will take quite a while and there’s no status. Just let it run (and if you’re on ssh, make sure your device has something to prevent it from disconnecting).

Hello! Can I ask how you created a dedicated, empty microsd card that has the bootloader installed? I get to the point where I have used the ‘cat’ command and the system transfers correctly, but then I am lost with how to install the bootloader on the card that I have to boot up to access the git command, etc. Do I have to do this from a separate computer? Do I use a sdcard to usb stick and install the bootloader on that one?

This tool is used to flash the bootloader. I haven’t used it, but there appear to be clear instructions for it.

You can use a usb adapter or a separate computer as far as I know. As long as the sd card is connected to a Linux computer with the flash tool, you should be good.

1 Like

I may be a bit late to the conversation, but I have been having a related boot issue.

I am using a renegade elite (ROC-RK3399-PC-Plus). The box doesn’t say -Plus, but the board layout is equivalent to the Plus, including the 4 tall SPI pins. That being said, I believe that I am unable to get it to boot off of a USB drive after flashing a boot loader to a micro SD as described above. The red and green LED illuminate and stay illuminated without ever flashing or changing.

I tried putting Debian, Ubuntu, the custom version of Raspbian/RaspberryOS, and Armbian with no luck (both headless and desktop environments were tried when available).

When flashing the OS to an SD card, the LED’s underwent the normal booting process (though I haven’t been able to get a display output yet. I haven’t tried multiple USB C docks so that’s a separate issue that I have yet to debug).

boot loader flashing →
outputs received and commands issued:

**bash dev-list**

**sudo bash bl-flash roc-rk3399-pc sda**
1850+0 records in
1850+0 records out
947200 bytes (947 kB, 925 KiB) copied, 0.222271 s, 4.3 MB/s
BOOTLOADER_flash: bootloader written to sda successfully.

Any help would be appreciated, thanks!

Do you have a picture of the board and can you let us know where you got it? ROC-RK3399-PC-Plus is an entirely different board that we did not design and our software will not support.

Sure. I didn’t know your boards were that different from the firefly ones. I am probably wrong then.

That is the new 1.2 revision with single chip LPDDR4. We are getting two in the lab tomorrow for testing so we can let you know then.

Ok, thanks for the info! I’ll keep an eye out for your results.

Any update on working with rev 1.2?

The bootloader work is already complete. Flash this file to an empty flash drive and update the SPI NOR.

We are working to fix USB PD issues so you may have to use a dumb power supply in the meantime.