Bricked La Frite after BIOS firmware update

I’ve had my La Frite since getting it as a Kickstarter perk. I set up a USB stick with a Debian image at the time and got it running but then largely forgot about it. I tried to flash a new UEFI BIOS to it using the instructions on the firmware flashing thread Libre Computer Board BIOS/Firmware Update Images , and once I finally got a working spiflash USB, the flasher ran, appeared to error out (with a checksum mismatch) and now it seems like I have a bricked board.
This was only yesterday, using the latest spiflash img file (so should have the HDMI fix) but have no idea where to start to find out if the board is working (but “blind”) or totally dead (the LEDs come on so… Maybe??)

I’ve attached serial UART and when I power up the board (with a flashed Debian image on USB) I get the following string coming back (on loop):

So I guess the board isn’t dead, but where do I go next?

I have the exact same issue (already discussed in AML-S805X-AC La Frite How to Update Board UEFI BIOS Firmware) when connecting my lafrite via TTY serial console.
Maybe @sserantes found a way to boot/flash his lafrite in the meantime?
So far I was unable to “manually” boot a linux-image using from pyamlboot.

You can use pyamlboot to flash the spiflash image to the eMMC. The board will boot to the eMMC and then re-flash the SPI NOR.

I’ve tried this a couple of months ago but I was unsuccessful - could you provide a sample script for that re-flash through pyamlboot please?

Any guidance on how to fix this issue? I followed the instructions to flash the firmware and now have a bricked device!