Enabling and using UART

Hello All,

I am trying to enable serial communication with the ROC-RK3328-CC (Renegade) board without any success.

The following are the main things I have done in an attempt to get the UART working and the parameters I am using:

I have retraced my steps and I am still not able to communicate with the system using UART.

Any insight as to this problem would be much appreciated.


First update your system. Then use the libretech-wiring-tool’s ldto command. It’s built into the images. Per libretech-wiring-tool/libre-computer/roc-rk3328-cc/dt at master · libre-computer-project/libretech-wiring-tool · GitHub, both UART 1 and UART 2 are supported.

Make sure your serial cable supports 1.5Mbps baud rate.

When using the ldto command, the available overlays do not show a uart overlay. See picture below for the available overlays:

Screenshot 2023-04-21 at 10.27.54 PM

Any ideas why this is?

I am using the ROC-RK3328-CC (Renegade) board.


Update your system as instructed.

Perhaps my understanding of updating the system is not what you intended.

I am doing the following to update the system:

sudo apt-get update
sudo apt-get upgrade

I even tried reinstalling the libretech-wiring-tool pakcage from git again through:

git clone GitHub - libre-computer-project/libretech-wiring-tool
cd libretech-wiring-tool
sudo make install

I am still getting the below:

Screenshot 2023-04-23 at 5.31.14 PM

Am I updating the system in the correct way?

Thanks again

Use sudo ./ldto list instead of the system one.

Where do I find a list of serial cables that are confirmed to support 1.5Mbps?