GRUB error on Ubuntu 20.04 with Libre Renegade ROC-RK3328-CC

I’m trying to use the ROC-RK3328-CC as the controller for a hexapod robot. I followed the instructions in Ubuntu 22.04.1 Jammy LTS for Libre Computer Boards to a T. I downloaded the image associated with my board “ubuntu-22.04.1-preinstalled-server-arm64+roc-rk3328-cc.img.xz”, I extracted the image using 7zip, and I flashed it to the recommended microSD card–a SanDisk Extreme 128GB–using Win32DiskImager. It wrote successfully to the SD card, but then when I go to verify it, it says it "Verification failed at sector: 2048. I don’t understand what’s going wrong, but I proceeded anyway.

I put the SD card in the board and started it up, created a new password, and then tried to run sudo apt update and then sudo apt upgrade, but partially into that, I get an error saying “GRUB failed to install to the following devices: /dev/mmcblk1p1”. I’m given the option to continue anyway or install GRUB. If I choose to stop and install GRUB, it says:

“The grub-efi package is being upgraded. This menu allows you to select which EFI system partitions you’d like grub-install to be automatically run for, if any. Running grub-install automatically is recommended in most situations, to prevent the installed GRUB core image from getting out of sync with GRUB modules or grub.cfg. GRUB EFI system partitions:
[ ] /dev/mmcblk1p1 (268 MB; /boot/efi) on 127865 MB ???”

When I select that, it then tries to run grub-install, but fails again telling me “failed to install on /dev/mmcblk1p1”. This brings me back to selecting whether I want to continue anyway or not. I’m stuck in this loop and I don’t know how to fix it. I’ve been banging my head against a wall for days trying to just get this to work. Any suggestions would be appreciated.

Don’t select anything. Just continue.

When I continue, it just gives me the same error that it failed to install GRUB and loops me back to that same selection screen.

Because you have the first option selected. Disable the first option.

I’ve tried both options. If I select yes and continue anyway it tries to run grub-install and fails again, bringing me back to that screen. If I select no, then it asks me which partition I want grub-install to be automatically run for. The only option I’m given there is /dev/mmcblk1p1 in /boot/efi. When I select that, it tries to install GRUB again and then fails, bringing me back to the first screen again.

Do not select anything, just continue without having any device selected.

There is no way to not select anything. The only option presented is “/dev/mmcblk1p1 (268 MB; /boot/efi) on 127865 MB ???”

Unselect that device and then choose continue.

Sorry, but how do I unselect it? Hitting enter just selects it and tries to install grub.

Hit tab and then press space.

So I don’t need to install grub at all? I thought I’d need it to boot ubuntu properly.

GRUB is already installed. There’s no need to install it again.

Understood. Should I be concerned at all about the image file failing verification when I flash it onto the sd card?

No, that is because you have automount enabled in Windows. Windows mounts the drive and modifies the data. Disable automount to avoid that error.

That seemed to work, although the only error I got was:
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish”

Is this an issue, or should I be fine now to continue installing ROS?