Le Potato Not Booting (Read)

Hello, Just got my S905x and I am having trouble booting this thing. I took the liberty of reading all the documentation and posts on the forum but I cannot get this thing to boot. Here’s what’s going on

  1. Downloaded the correct S905 Image from the Distro and Unzipped
  2. Flashed with Raspberry Pi Imager, Etcher, Disk Utility (No success), and even the terminal commands
  3. Pop the SD Card into the Potato (This card)
  4. Connect Ethernet
  5. Power on device

I see the Libre logo, then it goes through the Ubuntu System check. The loading mouse appears momentarily before the device loops again to the beginning Libre logo and the cycle restarts.

Reading the forums, I see that a common issue with this is either the SD Card, Power Supply, or Imaging method. I can confirm that the red LED (indicates power) does not turn off at all during this process. Additionally, I can confirm that the image is flashed correctly as this is the process with all the imaging methods. I am seeking assistance as to why this is not starting up. Perhaps a thorough video tutorial for each operating system (Windows, Mac, Linux) would be helpful.

I have a long history of working with Pi and other computer boards, this one has me stumped. Thanks in advance

Hi, I’ve just finished the same thing. It worked for me. I saw the EFI screen, then a grub screen, and then a boot log until finally a black screen with the “wait” wheel. That churned for some time, and then I got the purple jellyfish and System Configuration started.

Only thing I can suggest is to check the download image file (there are 905 and 805 images that might be easy to mistake) - and then try a different power supply and cable. If you have one of those RPi supplies with USB-C and then the little adapter for micro USB - I would give that a try. I’ve had trouble in the past with the USB cable itself - so try both a different AC adapter and also a different USB cable.

One more thing - if you are used to RPi, then the uSD card holder is different, you need to push the card in until it clicks like a ballpoint pen. And push again to release it. (Sorry if I’m just typing the obvious)

Good Luck!

1 Like

First and foremost, thank you for a USEFUL answer instead of telling me to just read something. I appreciate it, truly. There is no such thing as the “obvious” in this tinkering world.

I got it to work! I tried switching the power supply and cable. First I was using an android phone charger and a standard Micro USB cable, I then switched to some other USB outlet and changed the cable and it worked! Unsure why the android charger wasn’t good enough – or perhaps it was the cable ( I was maintaining a solid red light the whole time).

Anyways, thanks again!

Just like on the previous threads, if the board reboots instanteously, it is the power supply not delivering enough current. Most old Android phone chargers are 500mA to 1A.