No sound through HDMI

How did it “crash”? Also check your sound settings on the TV. Raspbian will play sound during the setup step via a screen reader.

I’ve been having the same issue until a moment ago. I ran alsamixer and found this setting…it was disabled by default. I had to change it to I2S before I heard sound on my tv through hdmi. Maybe yours is also disabled?

I am new to the aml-s905x-cc platform and have the same problem of no HDMI audio output with your “2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz” image. What I have discovered is installing without applying apt upgrade gives:

uname -a

Linux raspberrypi 6.0.12-00858-gb98721ea4575 #1 SMP PREEMPT_DYNAMIC Thu Dec 8 19:08:19 UTC 2022 aarch64 GNU/Linux

aplay -Ll


Discard all samples (playback) or generate zero samples (capture)

Direct hardware device without any conversions
Hardware device with all software conversions
Default Audio Device
Default Audio Device
Direct sample mixing device
**** List of PLAYBACK Hardware Devices ****
card 0: LIBRETECHCC [LIBRETECH-CC], device 0: fe.dai-link-0 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0

and “# speaker-test -c2 -twav” plays audio out on the headphone/3.5mm AV Jack and on HDMI.

After apt update apt upgrade, I get:

uname -a

Linux LibreELEC 6.1.19 #1 SMP PREEMPT Sat Mar 18 14:45:52 UTC 2023 aarch64 GNU/Linux

“# aplay -Ll” gaves the same as above, but “# speaker-test -c2 -twav” plays audio out only on the headphone/3.5mm AV Jack. There is no audio on HDMI. Amixer shows the same settings before and after the upgrade.

I compared the above against LibreELEC and CoreELEC. Both play on both outputs. LibreELEC appears to identify the hardware as "card 0: LIBRETECHCC [LIBRETECH-CC], device 0: fe.dai-link-0 (*) [] ; Subdevices: 1/1 ; Subdevice #0: subdevice #0 ", the same as raspbian except they include hdmi as an Audio Output. CoreELEC identifies the hardware as “card 0: AMLMESONAUDIO [AML-MESONAUDIO]” with 3 devices and device0 includes hdmi as an Audio Output.

From the above, I see that there are different ‘drivers’ for the same hardware and that there appears to be a bug in the software upgrade. I haven’t be able to figure out where yet, but I’m not sure where I should be looking either.

Hope this is helpful to someone more experienced with the system and software to figure out the problem.

Run alsamixer and configure the last 3 fields to enable HDMI audio if it was set differently. See the screenshot.

The last 3 fields are set as ‘I2S’ ‘I2S’ ‘SPDIF’ in both images. Rpi 6.0.12 has HDMI audio. Rpi 6.1.26 does not have HDMI audio. Can you try to reproduce the problem. I know the easy solution is to stay with rpi 6.0.12.

Can you install linux-image-lc-lts-arm64 and see if that kernel has audio issues with your setup?

" sudo apt install linux-image-ls-lts-arm64" and rebooting fixed the problem. Thank you.
I now have kernel Linux 6.1.30.
Why did I need to install linux-image-lc-lts-arm64 to get linux-image-6.1.30 instead of just upgrading to it? Or is that a question for another topic?
Thanks again.

linux-image-lc-lts-arm64 is a metapackage that tracks our latest LTS (6.1 for now) kernel.

Thanks for the info. It helps my understanding of how it all works together.

hello, so im having similar problems to where im not getting any sound at all through hdmi or the audio jack. i’ve tried multiple cables, multiple OS’ and have not gotten anywhere. i installed ubuntu no luck and now have raspbian install and tried to check the settings in alsamixer and everything checks out. i really need the audio jack workin because its being used for a project where hdmi is already taken by a lcd module. I switched to a tv to see if i could get audio over hdmi to see if i could get audio at all to no luck. I dont know what to do at this point so i figured id try asking here. I’ve pretty much done anything i can find suggested on the internet. I havent tried the audio header pins because i dont know how to do that. Ive tried searching and cant find anything because that would also be a viable option for this project. Any help is much appreciated!

Do you have a screenshot of your alsamixer settings? Which board do you have?

i have the potato and my alsa looks pretty much like the other fellows screenshot. I also tried lakka, retropie, and batocera. Batocera is the one im hoping to use once i got audio figured out.

ACODEC OUT EN is muted. You have to press M. When did you get the image? This should be set by default on Raspbian.

i got the latest image like a day or 2 before i posted because ive been trying every OS that works with the potato. what you just suggested worked! i now have audio through hdmi. but i still dont have audio through the jack or with a usb adapter. When i plugged the adapter in, alsa shows it in devices but when i click it the settings for the adapter come up but sound still just comes through hdmi. and the audio jack just doesnt give me any audio or signs of life what so ever.

so i just read somewhere that the audio jack doesnt work when you have hdmi already in use. is that true? because that would make sense. i highly doubt the board is faulty, everything else seems to be fine. im using an lcd driver board and lcd panel for the project i mentioned, so audio and video are separated since the lcd driver board doesnt do audio (to my knowledge). Which header to you use for audio and which for video with the s/pdif header or the adc + i2s header?
and can anyone point me to a guide on how to setup/use them?

Audio can be routed to both simultaneously.

still cant get audio from anywhere other than hdmi for some reason

Thank you for your continued help on the matter, project got put on hold because of a problem with the lcd but im back to it. im using the batocera image from the le potato official downloads.
I can get audio through hdmi and a usb audio device with headphones but yes the problem is i cannot get it to work from cvbs jack.
I set up alsa the way it should be based on our discussion before and the link you posted to the troubleshooting post and i have everything matching.
I tested the voltage coming in with a multimeter and im getting right around exactly 5V, 5.1ish but never under 5. My power supply is rated for 2.5a so i dont think thats the problem.
What i think i might need to do is set alsamixer fields like you said, how do i go about doing that?

Did you unmute the field we told you about last time?