Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

You can just run make at the base of the directory. You don’t need to add flags or cross compile.

There are two ldto commands, 1 is the system ldto and 1 is the current directory ldto.

When you run sudo ldto enable i2c-ao-ds1307, it will search for the system one. You need to add ./ in front of the ldto to use the ldto in the current directory.

Make sure to enable i2c-ao before i2c-ao-ds1307 though.

@degreaser I also bought the Le Potato and a Renegade in order to use a 4K Samsung display. So far it’s just not worked at all on either machine in Ubuntu 22.04.01 or Raspbian 11. However, I can help with something here. The #WARNINGS you see in your output are because there’s a bug in parse-edid v3.0.2 for large display resolutions. I reached out to Matthew Kern (current author of read-edid) and he gave me a patch to fix it. If you want the fix, you can reach out to him as well - he was very responsive to email. You can find the website and email by running get-edid -h

Both boards are designed for 1080P UI with 4K videos. For Le Potato, 4K is best with CoreELEC. For Renegade, Android 10.

Just wanted to report that I had the same problem yesterday. My objective was to get Pi-hole running on the Libre Computer Board AML-S905X-CC. The initial OS setup was not smooth, but it’s working now.

Since I want to run it headless, and only use it for Pi-Hole, I decided to go with the Raspbian / Raspberry OS ‘lite’ version. I downloaded this image:


Then following the install instructions I used the Raspberry Pi Imager (v1.7.2) to write to the SD card. Although I used the tool’s settings to customize the hostname and enable SSH, I actually got a device with the default hostname, no SSH, and the custom user I set up did not have its PW set (which was all a bit annoying to troubleshoot). Also, the locale and time zone settings were ignored. So I popped the card back into my laptop and followed the manual setup instructions, specifically:

 * To enable SSH by default, create a blank file called ssh with no file extension.
 * To setup an user by default, create a file called userconf.txt with one line in the format username:encrypted-password and replace username with the username you would like to use and encrypted-password generated from openssl passwd -6

(Except on that second bullet I copied the hashed PW from the ‘firstrun’ file in the root folder)

Then I was able to SSH into the device, change the hostname to the one I wanted, and then did the Pi-hole installation.

Bottomline: after using the RPI’s settings customizer the only piece that worked was that the user was created. No other settings transferred.

Hello. I was able to get my ‘Renegade’ setup. (I installed Raspbian) Just had a few things someone could help me with. First one, how to I transfer files from my SD Card over to my emmc memory card? I can’t seem to find an easy way to get do it. The other issue is with my external Wi-Fi card. So, I have both the SSH file and WPA file on the root of the SD card.

When I boot the system, It keeps giving me this error: “temporary failure in name resolution.” The wifi brand that was supposed to work is the: tp-link TL-WN725N. Not really sure what I’m doing wrong that it does not work.

So far, I just connect it to my portable router, then its setup to repeater mode (I think that’s what it’s called) and plugged into the Renegade. Works fine like that but, looking for a less messy solution. That’s basically the 2 problems I’m running into. Hopefully someone knows how to fix this. Would appreciate any help. thanks

  1. eMMC shows up as /dev/mmcblk0. If you plan to use it as the boot device, follow method 2.
  2. TL-WN725N has numerous revisions with different drivers. What is the output of lsusb?

Hey all! Me again, with a very similar question that I asked from https://hub.libre.computer/t/ubuntu-22-04-1-jammy-lts-server-release-notes/63/23:

I am attempting to use a few of these boards as a Kubernetes cluster. As a part of that, I am attempting to set up Ceph block devices with the rbd kernel module.

$ sudo modprobe rbd
modprobe: FATAL: Module rbd not found in directory /lib/modules/6.0.19-02541-gd380b952927c.

I think this means I need to rebuild the kernel with the rbd module. Any pointers on how I can resolve?

Did you run sudo apt update && sudo apt dist-upgrade?

Yes. sudo apt update && sudo apt dist-upgrade followed by sudo shutdown -r now. Did this on all three Renegades running Raspbian (2022-09-22-raspbian-bullseye-arm64+roc-rk3328-cc.img.xz from the distro server). After completing those steps:

$ sudo modprobe rbd
modprobe: FATAL: Module rbd not found in directory /lib/modules/6.0.19-02541-gd380b952927c

Confirmed the problem and fixed the config. New kernel should be uploaded in 6 hours.

Just got my first Le Potato and pretty impressed. A few specific python libraries aren’t configured for the board but other than that I can’t see too many issues vs a Pi 3.

I note the Normal Raspberry Pi Configuration is pretty non-functional but raspi-config seems to solve most configuration issues.

A couple of ‘dumb’ questions - Can I use the Raspbian update button or should I wait for new editions of customized Raspbian to be updated on the Libre Product software download page ?

Why does the Image boot with "dillo"as the stock browser ? I found Dillo impossible to use but the included Firefox browser seems to a perfectly functional normal browser.

You can just use normal apt update toolchain as Raspbian 11 is 99% Debian underneath already. Our update infrastructure is tied to apt so you will get kernel and userspace updates from us as well.

Dillo is what Raspbian includes as default. We try not modify distro (Raspbian) defaults to make the experience as close to stock as possible.

I’m trying to change the screen orientation in Raspbian (it’s upside down). Google says to click on ‘Screen Configuration’ in preferences, but no such option exists. What am I missing?

New to SBCs and Linux, so I can enter commands into the terminal but don’t know much more than that.

never mind. ran command arandr which opened it.

The Distro download server for the individual downloads seems to be down. Clicking on any of the images results in:

computer-libre-distro.us-east-1.linodeobjects.com ’s server IP address could not be found.”

Akamai Linode has a DNS problem that they are working to resolve. https://status.linode.com/

Thanks for the update! I can confirm that they must have fixed the issue and I am able to reach the images now! :smiley:

How can I create a password for a user on a headless system when I do not have access to another Linux system?

The file can be modified in Windows. The first partition is readable and automatically mounted. You can create the file in the base folder of the drive in Windows.

I’m following these instructions using the Pi Imager in MacOS, setting username/password under advanced and adding an SSH file to the boot partition.

Renegade seems to boot fine, terminal reports incorrect password when trying to login. I’ve reinstalled 5 times same result.

Any ideas?