Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

Yes, even with the lite image this is not working. I got it to the point where I can reach it on the network (add the supplicant.conf file) but then I get the warning that:

Please note that SSH may not work until a valid user has been set up

And it is clear that there has been no such user set up on first boot (the password I set up for it does not work).

The file is userconf.txt or userconf and not userconfig.


Now I feel foolish! :grinning:

But that’s an easy fix, so that’s very good. I definitely could not get it working from the Raspberry Pi Imager but it does seem to be working in this way.


Thanks for the report, we will check out the Raspberry Pi imager.

It looks like the files will work even with the full.

Yes, it should work for both. Can you please confirm that Raspberry Pi imager configuration doesn’t work for you? Are you able to use the tool and then check for the files after it finishes flashing?

OK. I seem to almost have things working the way I want on one board but I “broke” the setup on the other one so I tried doing the install again on that it.

For reference, I downloaded the ‘imager_1.7.3_amd64.deb’ file and installed the Raspberry Pi imager from that.

I did an eMMC erase.

I ran the script to make the eMMC show up as USB mass storage.

I used the imager and picked the ‘2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz’ image (so the full one).

There, in settings, I made image customizations setting hostname, checking ‘Enable SSH’ (set to use password authentication), set username & password, checked the configure wireless LAN box (I have a USB dongle) and entered those settings, set localization & for persistent settings clicked checked ‘Play sound when finished’ & ‘Eject media when finished.’ This was done with the image customization options dropdown list at the top of the dialog set as ‘to always use’. Then I clicked on the ‘Save’ button.

It didn’t put the obvious files (the obvious ones —the ones I used/altered when setting this up manually and that worked— are the userconf.txt, the empty ssh, the wpa_supplicant.conf and, under the /etc directory of the root, an altered hostname & hosts files), but it did place a script in the /boot mount (called ‘firstrun.sh’) that seems set to run first (it’s set that way in the boot parameters file) that included all of the information from the imager settings and that looks like it should do the right thing.

However, when actually booting the board it is still starting out by asking for localization information that should already have been set by the imager; as well as it asks me for a username.

P1 should be mounted at /boot/efi and not /boot if I am not mistaken as we prefer the normal setup paths on EFI systems. MicroSD vs eMMC shouldn’t matter.

Are you referring to these files you asked about?

It might be that I am looking in the wrong place.

When setting the board to be seen as USB mass storage, I get two new locations on my laptop (running Linux Mint). These are a boot location & a rootfs location.

Under the boot location, at the root of that, I can find the ‘firstrun.sh’ file that has been clearly customized by the imager.

Elsewhere, I have not found anything; but I don’t really know what I am looking for. If it’s something like userconf or userconf.txt, it doesn’t exist (under either boot or rootfs). If it’s something else (other than firstrun.sh), I do not know if it exists.

This is all after doing the imaging and before trying to boot it.

Booting, again, produces the dialog to set up the first user.

boot and rootfs are the partition labels, not the mounting points. You can find the mounting points in rootfs: /etc/fstab

Will check the firstrun.sh file and get back to you.

1 Like

I too had problems booting 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz first time. I used Win32 Disk Imager V1.0. It completed successfully. I tried to boot, no life. I ran verify on the uSD image and it failed.

Next I reformatted the uSD using the SD Association’s formatter (sdcard.org). This seems like a waste of time to me, but some post suggested this step if things fail. Next I burned the image with balenaEtcher.V1.5.79. I always have to start that as administrator for it to work right. Le Potato Raspbian booted right up, updated itself, and I’ve been running it ever since. The OS has been solid for me, and without glitches.

Overscan was my problem too. The Raspberry has a nice feature to easily compensate for overscan. It’s the raspi-config command that’s not available on Le Potato.

This was fixed through much trial and error plus research. BTW, xrandr was already installed in the Raspbian image I downloaded from Libre Computer, and I didn’t have to apt install it. I’m curious why the command is not available on your distro.

The best solution for the overscan problem is to check your TV’s menu settings to see if overscan can be turned off. My HDMI TV doesn’t have that feature.

If that fails, use xrandr to shift and scale your image. You can enter these commands in your terminal, sudo not required. This assumes you’re using 1920x1080 (1080p).60Hz refresh.

# This command scales the display and shifts it down and right.
xrandr --output HDMI-1 --mode 0x46 --transform 0.97,0,-48,0,0.98,-24,0,0,1
# This command brings the right and bottom edges onto the screen.
xrandr --output HDMI-1 --transform 1,0,-48,0,1,-24,0,0,1

The second xrandr sometimes complains about a parameter bad match, but it works.

If this doesn’t fix it for your monitor, play with the decimal numbers for scaling (0.97 for horizontal, and 0.98 for vertical). In the above, left/right borders are 48, and right/bottom borders are 24.

To make this change permanent on login, add these lines at the end of your ~/.profile file.

One important note. At first this might not look like it’s working when you look at the LXPanel. The reason is because LXPanel doesn’t seem to be aware of the screen dimension changes caused by the --transform, and it will be off the screen. To fix that, use LXPanel advanced settings to adjust the size and location of the panel. For me, 95% left-aligned panel with 5 margin worked.

Hope this helps.


Have you tried editing the /boot/config.txt file for the overscan options?

There are various overscan options there. I’m can’t say whether they work (as I have not tried editing them to see the results) but they do exist.

config.txt does nothing on our images and our boards. It is an Raspberry Pi specific file.

1 Like

/boot/cmdline.txt is also ignored, right?

Yes, per the download page, both cmdline.txt and config.txt are Raspberry Pi specific. If you need to set the kernel command line, do it the standard Ubuntu/Debian way.

Hello, Can I use Raspbian os 64bit from raspberrypi for ROC-RK3328-CC (Renegade) ?

Or where can I download a Raspbian os 64bit from libre distro ?

Thank you.

The link is at the top.

Done! Still doesn’t work with the latest kernel. Again, thanks for the help to get it working on an old monitor. Nice to know what the problem is.


I am using AML-S905X-CC. I have tried with.

  1. Ubuntu ( ubuntu-22.04.1-preinstalled-base-arm64+aml-s905x-cc.img.xz )
  2. Raspbian OS ( 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img.xz )

Everything works fine, But i can’t print using my Brother’s Printer.
In Ubuntu it is printing one side, when it comes to double side printing it is not working.
In Raspbian, Not even triggering the print.

I am using Brothers HL-B2000D Printer.
Using cups for printer setup.
I have tried with variety of drivers. Still the issue remains.

If you have any idea, please look into this as soon as possible.

Thank you.