Raspbian 12 Bookworm and 11 Bullseye for Libre Computer Boards

can ya send me a link for the raspbian image for the s905x

Double check your MicroSD card and power. Just tested the image with your instructions and could not replicate the problem.

1 Like

I think the issue was my capture device (instead of monitor) wasn’t registering video input consistently. I changed the displays and HDMI cable, and it looked fine. Thanks for responding. Sorry I took you on a wild goose chase.

1 Like

No worries, better safe than sorry.

Just downloaded Raspbian 11 and booted to desktop just fine. However after update and reboot, get a blank screen. It appears to be up after reboot, but since I haven’t enabled ssh, I can’t login to it, I get a “port 22: Connection refused” message. Can you reproduce?

edit: for ROC-RK3328-CC

What display do you have? Make and model?

Just installed an older version of Armbian, the latest won’t boot to the desktop. After updating, X windows won’t start either, but am able to ssh in.
dmesg shows:
[ 450.963571] hdmi-audio-codec hdmi-audio-codec.4.auto: Only one simultaneous stream supported!
[ 450.964620] hdmi-audio-codec hdmi-audio-codec.4.auto: ASoC: error at snd_soc_dai_startup on i2s-hifi: -22
[ 450.965743] ff000000.i2s-i2s-hifi: soc_pcm_open() failed (-22)

Here is the relevant portion of Xorg.log:

[ 56.329] (EE)
[ 56.329] (EE) Backtrace:
[ 56.331] (EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x188) [0xaaaaca8e9848]
[ 56.331] (EE) unw_get_proc_info failed: no unwind info found [-10]
[ 56.331] (EE)
[ 56.331] (EE) Segmentation fault at address 0x34f
[ 56.331] (EE)
Fatal server error:
[ 56.331] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 56.331] (EE)
[ 56.331] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 56.331] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 56.331] (EE)
[ 56.418] (EE) Server terminated with error (1). Closing log file.

This makes me think there is an upstream problem with the gpu on rock chip based products (ie Mali)

Is there a distro (any) that has a working desktop after update?

for completeness, I have tried two different monitors, LG 32QN55T and a Samsung which I don’t have the model of at the moment.

Thanks for the fast response!

Probably more relevant xorg logs :wink:

cat /var/log/Xorg.0.log | grep EE
[ 56.145] Current Operating System: Linux renegade 5.15.76-rockchip64 #22.08.8 SMP PREEMPT Sun Oct 30 10:57:32 CET 2022 aarch64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
[ 56.196] (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument

You have to use the Armbian support forum for those images. We do not maintain the Armbian images and they do things quite differently. If you have issue with our images, post here but please don’t mix your Armbian image problems with problems with our images as it becomes very confusing. Both our server and desktop images should have proper X11 configuration.

Fair enough, thanks for your help so far.

I’ve made significant progress with the Raspbian image.

The original Raspbian image boots fine, but after update my Samsung 2443BWX monitor with hdmi to dvi adapter no longer recognizes the renegade. However when I plug into the LG it works fine and when I plug it into another old monitor it works fine as well.


Another weird thing with this image. The reboot command (shutdown -r now) actually halts the renegade not reboots it. Same when selecting reboot in the gui.

Regardless I now have a working image, albeit with some oddness.


1 Like

Can you check with the latest kernel?

sudo apt update
sudo apt dist-upgrade

We had to revert some patches that broke other things. Can you please post here: ROC RK3328/RK3399 No Video on Monitor

I am completely new to the libre boards, but very well versed in the rpi world. Looking for alternate hardware options these days.

I have so far been completely unable to get any signs of intelligence from 2 brand-new le-potato boards. No matter what image I try, using rpi-imager, win32 imager, all I get is the solid red and blue LEDs. HDMI never turns on, just a lot of nothing.

Tried multiple dedicated USB power supplies that are known good and I don’t see the LED go out ever.

I have been following this page, but seem to be banging up against something fundamental.

Any ideas where I might be going wrong?

Probably flashed the wrong image? Did you download the right file with +aml-s905x-cc.img.xz and extract it before flashing?

Yes, I have been using the 2022-09-22-raspbian-buster-armhf+aml-s905x-cc.img.xz and 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc.img.xz images, extract them with 7-zip to a folder where the img files reside respectively


I then burn them to a 16GB flash disk using win-32 disk imager. Extract the card and install in the OBC and power up. Blue and red leds only.

Tried a bunch of images, and finally found that the Armbian Bullseye CLI image will boot, so I know the hardware is good finally, but would like to understand why all of the raspbian images are not working.

Can you confirm on your hardware the images that are currently hosted are functional?

The only raspbian one I got any sign of life on (a barely perceivable green flicker) was the 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc.img. Beyond this green flicker, no signs of life beyond the blue and red leds

I then burn them to a 16GB flash disk using win-32 disk imager.
MicroSD card or USB stick? USB sticks won’t work.

Can you confirm on your hardware the images that are currently hosted are functional?
The images are all CI’ed meaning that they’re tested before being uploaded to the server.

Please see the general troubleshooting page. Your issue is either flash corruption or power if more than one board is experiencing the same issue. The green LED should turn on if the bootloader was flashed correctly.

Same here. Exactly the same.

I was curious and had some time, so I did a quick check. I downloaded the latest 2022-09-22-raspbian-bullseye-arm64+aml-s905x-cc.img, flashed it to a new SanDisk Ultra 16GB card, and it booted right up first try, prompted me for the usual first-boot questions and is installing updates right now.

I personally use Balena Etcher to flash my images (which isn’t recommended), but other than that I have a pretty standard test setup. 2A tablet power supply for the Potato, Ethernet connection. Using a generic HDMI USB-C-powered monitor connected to a separate power supply, generic wireless keyboard/trackpad combo.

In the time it took to write the above, the updates finished and after rebooting I’m into Raspbian and it seems okay.

I verified the checksum of my downloaded image against the one listed in the SHA256SUMS file and it matches.

EDIT: Just went through the same test sequence with 2022-09-22-raspbian-bullseye-arm64-lite+aml-s905x-cc.img and it appears to work okay as well.

We don’t track Balena Etcher changelogs but previous version included some optimizations that screwed up images. To avoid said optimizations asking users what version they use, we just advise users to avoid it altogether. That said, the latest Balena Etcher will probably work fine.


I am having the same issue here. I tried both methods: using the Raspbian imager & doing an image copy & adding the userconfig file & the empty ssh file.

I currently have access to HDMI monitors, to a USB pointer device (trackball, actually) but do not have access to a USB keyboard so I thought I might ssh from my laptop to set up various things. This implies I need some kind of a headless setup.

Do we perhaps need to use the lite image for this to work or am I missing something other step to get this to work. I would, at some point, need the full image rather than the lite. The install was on an eMMC and those steps seemed to work without problems; but like jtrmal, on the first run it still was asking me to set up an account.