Renegade Booting with Bad SD Card, But Not Good One?

I’m trying to boot Ubuntu Desktop on a Renegade. I can successfully boot every time off an old Kingston 8GB SD Card with a write speed of a meager 5 MB/s. The performance is pitiful, of course. I was only using the Kingston as a proof of concept, and immediately went to upgrade to a recommended card. I purchased a SanDisk 32 GB SD Card with a maximum write speed of 120 MB/s (in practice, my rig seems to max out at about 50 MB/s) and flashed the same image to it, but the board never boots. It doesn’t even get to the “heartbeat” stage. When I switch it for the old Kingston, it boots up without issue.

I’m at a loss as to why this may be. The SanDisk card looks to be in excellent condition and it works perfectly otherwise. I figured I’d ask and see if perhaps I’m missing something obvious before returning the SanDisk or buying another card.

We have discovered software boot inconsistency issues with Renegade, we are looking into it.

My experience with the renegade that I just received from amazon: I tried the Ubuntu, bullseye and buster images and always get the same behavior. The board will boot normally the first time only and when I do shutdown -r now it will just shut down. Upon reapplying power, the lights stay solid and nothing else happens. It is headless so this is all I see. Armbian works as it should.

I was having a similar issue with “Le Potato”, as well as the device will not reboot if I am using the OTG port. While attempting to triage the latter issue, I tried “apt install watchdog” after reading How to Shutdown Libre Computer AML-S905X-CC Le Potato and When nothing is connected to the OTG port the system now reboots as expected. You may want to give it a try.