RESOLVED: Connection Refused on Fresh Base Install

Hello all,

Just some quick background. I am very familiar with Raspberry Pi’s but this is my first time using a Libre Board.

Today I am using the Renegade and am attempting to use the Base Ubuntu 22.04 build from the Libre website but I am experiencing trouble SSHing into the board.

Just to minimize the possibility that I did something silly (which I probably did), I’ll quickly walk through the steps I followed to get to where I am.

  1. Downloaded ubuntu-22.04.1-preinstalled-base-arm64+roc-rk3328-cc.img.xz (which matches the naming convention for the Renegade, and what’s stamped onto the box that this board came in) onto my PC.
  2. Flash the .xz file onto SD card with BalenaEtcher (Successful)
  3. Plug SD card into board
  4. Plug Ethernet cable into board
  5. Power board (LED’s are on)
  6. Get IP address from Router (Board named “roc-rk3328-cc” and issued IP
  7. Use Terminal to SSH into board:

ssh root@

(I also tried without the “root@” to no avail)
(I also, also tried to connect with PUTTY, but that didn’t work either)

I keep getting

ssh: connect to host port 22: Connection refused

and I’m not sure why. I don’t believe I’m doing anything differently than I would on one of my Pi’s. Is there an issue with SSHing with the “Base” image for the first time? Or is there something else? I THINK the image is good, or else my router wouldn’t be showing the “roc-rk3328-cc” device; but I could be wrong there. Perhaps the “Uboot” button needs to be pressed for the first boot?



I don’t believe the base image includes ssh/sshd by default. See

1 Like

Ahh, seems you are correct. I’d have to enable SSH from the GUI before I could run it as a headless system.

I’ll check out the Server image and see if that gives me what I need.


Yep – otherwise, everything you did looks correct and appears to have been successful… so you’re close!

The links to the release notes of the various images can be found at if you need them.

I generally do interactive installs before I go headless, so I can’t speak to pre-configuring and such; but others have documented their experiences in those threads.

Good luck and enjoy!

1 Like

The Server image worked exactly as I needed.

Thank you again for your help!


Excellent. Glad to hear it.