Troubleshooting Boot Issues on Libre Computer ROC-RK3328-CC Renegade

Yesterday I erased my microSD to start over fresh. I had Ubuntu Server 22.04 running well for a while, but was troubleshooting a separate issue with my microk8s setup and decided to start fresh. After erasing my card and re-flashing the latest image from the distro server, I cannot for the life of me get this thing to boot. The green LED blinks once when first powering on, and then never again. Red LED is on solid. I’ve waited minutes/hours, etc. I tried a new SD card. Both cards multiple times. Verified everything I can think of and that I’ve read on these forums. Any suggestions would be greatly appreciated.

Make sure Win32DiskImager verify cycle is able to pass per the troubleshooting guide.

See exactly what the board is doing:

Got the UART cable and was able to connect to observe boot behavior. We’re stuck in a reset loop, due to “cannot determine file size”

U-Boot 2023.07+ (Sep 17 2023 - 00:56:34 -0400) Libre Computer ROC-RK3328-CC

DRAM:  4 GiB
PMIC:  RK8050 (on=0x40, off=0x00)
Core:  244 devices, 31 uclasses, devicetree: separate
MMC:   mmc@ff500000: 1, mmc@ff520000: 0
Loading Environment from FAT... Unable to read "uboot.env" from mmc1:1... 
Error (-2): cannot determine file size
tmdsclock = 594000000; chipversion = 1
"Error" handler, esr 0xbf000002
elr: 000000000027a8a0 lr : 000000000027a828 (reloc)
elr: 00000000fe7338a0 lr : 00000000fe733828
x0 : 00000000ff080064 x1 : 0000000000000000
x2 : 00000001007a4000 x3 : 0000000000000000
x4 : 0000000000000000 x5 : 0000000000000000
x6 : 00000000ffffdff1 x7 : 0000000000000000
x8 : 0000000000000001 x9 : 000000000000000d
x10: 0000000000000006 x11: 000000000001869f
x12: 0000000000000000 x13: 0000000000000000
x14: 00000000ffffffff x15: 00000000f66a6b9d
x16: 0000000000001140 x17: 0000000000000000
x18: 00000000f66b7da0 x19: 00000000f66c4a10
x20: 00000000f66b93a0 x21: 0000000000000000
x22: 0000000000007fff x23: 0000000000800800
x24: 00000000f66c6ff0 x25: 00000000fe7d8598
x26: 0000000000000000 x27: 0000000000000000
x28: 0000000000000000 x29: 00000000f66a7300

Code: 78002415 17fffff2 f9401260 8b020002 (eb00005f) 
Resetting CPU ...

resetting ...
PMIC:  RK8050 (on=0x40, off=0x00)
DDR4, 800MHz
BW=32 Col=10 Bk=4 BG=2 CS0 Row=16 CS1 Row=16 CS=2 Die BW=16 Size=4096MB
Trying to boot from BOOTROM
Returning to boot ROM...
Trying to boot from MMC1
lz4 image
NOTICE:  BL31: v2.9(release):v2.8-1351-g8929dffc0
NOTICE:  BL31: Built : 00:56:31, Sep 17 2023
NOTICE:  BL31:Rockchip release version: v1.2


U-Boot 2023.07+ (Sep 17 2023 - 00:56:34 -0400) Libre Computer ROC-RK3328-CC

DRAM:  4 GiB
PMIC:  RK8050 (on=0x40, off=0x00)
... (and so on)

I’m not sure what to make of this. I’ve tried 3 different SD cards which have all been tested good on this machine or on one of my RPi. Tried the Ubuntu 22.04 image as well as the latest Raspbian image. The verification pass produces no errors… any advice? I’m about ready to toss this board.

This is a display compatibility issue causing an exception. What monitor do you have?

It’s a Dell S2721QS. That’s interesting because it has worked fine for me with this board up until now.

We recently added support for video output on RK3328 during early boot so the new code is causing the exception-based reboot.

Ok, that explains why it worked before since I first set it up about 6 months ago. I can confirm that without the display connected, the green LED is blinking normally and the RJ-45 lights show activity so I’m assuming I’ll be good now if I connect it to a different display.

We will work on this and improve the situation. Thank you for bringing it up.

Indeed. Removed HDMI cable and the board boots. This was working fine for the longest time and recently, I assume via some update as indicated in other comments, it started to have issues with the display driver, sometimes booting but failing to load the driver falling back to a basic display (resolution is very low). This morning it must have rebooted and didn’t boot until I disconnected the hdmi cable. After boot I could connect it and ubuntu started correctly.

Same monitor forever. Monitor is a LG 24MC57HQ-P

We will have this issue fixed in a few days.

1 Like

I ran into the same problems with the Debian 12 image that I had flashed to eMMC. I haven’t seen it stated in this thread, so I thought I would share the work-around that got me moving -

  1. Start with the machine disconnected from everything.
  2. With the power supply off, connect everything except the HDMI cable to the board
  3. Apply power to the board (i.e., turn on the P/S switch or whatever you need to do to connect power with your setup).
  4. Confirm that the red LED has turned on solid. The green LED may come on for about a second, then go dormant for several seconds
  5. After several-to-many seconds, the green LED will start blinking indicating the OS is loading
  6. Connect the HDMI display at this point and things should be working as normal for whatever December 3, 2023 dated image you are attempting to load

It is noteworthy that this is necessary (to disconnect the HDMI cable until the process has past the bootloader and hardware identification phases and starts to load the OS) to do this on subsequent re-boots as well. I will also test with an SD Card to see if the behavior matches what I am seeing with the eMMC media.

I share this because this kind of thing may not be intuitively obvious to everybody as a work-around to get started with a new image until the fixes can be implemented and released in a few days as mentioned previously. Once the fix is identified, verified, and tested, I assume new official images will need to be generated and released for public consumption that will resolve this.

For what it is worth, I experienced the same problem with an Armbian 23.11b image and it is presumed that this is the same fault. I haven’t looked over on their forums yet to see what is going on, but I think the Armbian team might benefit from a heads-up about this to either fix what ails their image or at least give them the information that will help them arrive at a functioning boot experience with their latest releases for this hardware.

I also tested with the SD Card instead of the eMMC, and my experience showed the behaviors to be the same regardless of type of media. I’m looking forward to seeing either an updated set of affected images with the fix or instructions on how to fix the current images as either (or both) become available.

This is a known issue and will be fixed later this week. It was due to the new u-boot video handling code which we have cleaned up.

Was this fix applied? I just flashed debian 12 on a new Renegade and it won’t boot with HDMI plugged in. The latest debian image is dated just a few days after the above post (Jan 25, to be precise).
I found this thread and got it booted, and ran apt update && apt full-upgrade hoping to bring this fix in through an update, but it still won’t boot with the display plugged in.