Ubuntu 22.04 and updated mesa

I got my 2g LePotatoe and eventually found the server image for 22.04.
Please seriously consider adding more WiFi drivers to server image as none of my realtek nor ae6000 worked…
Eventually I installed desktop image… please consider adding an image for fceux or xubuntu.

But to my serious question… mesa 23.1.0 is unstable (leaks as handles for dummy are not release) - will manifest as DRM_IOCTL_MODE_CREATE_DUMB failed: Cannot allocate memory, Failed to create scanout resource.

I did not see a proposed package for mesa 23.3.7 supposedly fixes; so installed and compiled from source. I must have done something wrong, because though the memory issues seem fixed, the performance is poor and some others -gtk fail. (mame is giving me 10% on asteroid)

Also, glmark2 segfaults regardless /w opengl. I’ve been using the gles renderers.

My interest is emulation an ml applications; really don’t want to fix drivers. Many thanks.

These are Ubuntu issues and not something we can fix. They are using older library versions for 22.04.

You can install xfce, or any desktop you like, on any ubuntu image through the apt package manager. I think the command is:

sudo apt install xubuntu-desktop

Also on the wifi adapters:

Yes, and 8821cu is one of the adapters I had. Though I realize I can install any desktop, the issue is not having wifi to get it (and not having a wired network in my home anymore). Also, wpa seem to be incomplete in the server image. My network uses wpa2-personal with ccmp and tkip. It refused to authenticate… but same supplicant config worked when I installed desktop. My request for an image is to avoid spending days on configuration just to get to login prompt and then internet connection. I want to flash and go… flash and start building or configuring apps.

Yeah, I guess that’s rather inconvenient. I’d love to see a Xubuntu or Mate image; I don’t really care for the new gnome, and it doesn’t seem ideal for a 2GB SBC. That said I’m also not the one who has to maintain all this, and it’s not that hard to DIY it with the -buntu’s, so I try not to grumble.

In the mean time, you could set it up how you want it once and make an image of it. I just did this with Ubuntu Mate. All my must-have apps, startup scripts, appearance settings ready to go. Aside from the large file size, I actually much prefer this method. It’s almost like having my own personal distro. Panels just where I like them and everything.

I think the server image also comes with weston, it shows up as a log-in option every time I install a desktop. I barely used it, but it may be helpful getting things set up. I think it’s still all the same under the hood, so it may not solve the wpa problem. I just shared my internet connection from my desktop for my initial Mate install. It pays to keep at least one cat-5 cable kicking around, even in the age of wifi.

Use netplan per the release notes on the server images to setup WiFi.

You assume I did not.

Yeah, I did have a long cable and drag it to my router - and took the path you suggested (just installed mate). I have been using weston to do configuration work - but I am now in a place a didn’t want to be. I believe I have rebuilt mesa, mali, lima drivers correctly - but I am missing something in wiring it up in X. In the old days, I’d just make sure the vesa drivers were in xorg.conf to get 2d and 3d acceleration. Now - it looks like the 2d acceleration is just gone… and I am totally unfamiliar with the new kernel base mode detection stuff. And it looks like I can’t create the xorg config as long as that is enabled. A dude on the mesa forum suggested I look at the recipes for a stable build, to learn how it was set up… but navigating linux configuration isn’t where I wanted to be on this project. I will keep trying, as I hit similar blockers with other linux distros and sbcs.

This is much too complex for the average person. If you are not familiar, there’s a very large learning curve. Most instructions online are out of date.

Either run Armbian if you need X11 or one of our images if you want to run wayland/weston.

armbian does look promising… will try its 23. /w 6 kernal xfce image