Ubuntu 22.04 Jammy LTS for Libre Computer Boards

I tried compiling a few missing modules (/pps/clients/pps-gpio and /tty/serial/sc16is7xx with both i2c and spi support), unfortunately there’s a mismatch in the kernel version between what’s available on github (5.19.6) and the latest pushed by updates from the Libre Computer repository (5.19.8-03347-g542d481c2a42).

Would it be possible to either update the github kernel to that version, make the source for the matching compiled kernel available directly on the repository or enable those modules in your next build?

1 Like

It should be pushed to the deb servers by CI shortly. You can open a GitHub issue with the configs you need in the future. As for the code base, you can just fetch stable and then rebase.

1 Like

Thanks! It will take me a little while to try it out.

apt update
apt dist-upgrade

Saw the modules in the new kernel, thanks! I’ll base myself off the other overlay files to write a few that will work with them. I don’t believe the libretech wiring tool / the ldto script in its current version can take arguments when enabling an overlay?

The ldto tool is just a bash script that copies files around. It has no knowledge of parameters but this could be added. I recommend you open a ticket if you have a maintainable way of feeding parameters to the DT overlays.

I don’t have anything of the sort unfortunately, but I’ll see if I can find anything.

I’m getting started with my board and initially downloaded the Ubuntu 22.04 image as of approximately 20220911-0200UTC. I bought the board with the 4K capabilities in mind, with the goal of writing my own signage player to meet our specific requirements.

However, as soon as I hook a 4K display up things get strange. Switching the cable from an HD display to 4K while booted will not bring up the 4K display, though I can switch back to HD and get the display back. If I boot with the 4K display hooked up, it will display just fine, but as soon as the screen goes blank after a while, it never comes back. Again, switching back to an HD display still works.

I don’t specifically need Ubuntu, and in fact will want to go with a much slimmer OS long-term anyway, but I figured reporting this behavior may help somebody. In the meantime I’ll try a different distro for now and see what happens.

FYI this doesn’t appear to be happening with Armbian.

The board is designed for 4K media, not really 4K UI. It can drive 4K display but it will be slow. Some features like 3D graphics don’t like 4K textures so acceleration will work funny. To debug the replug issue, run dmesg and send a pastebin of the output.

Hi There!

Sorry if this is a dumb question, but I’m a bit new to the Libre boards.

I have an AML-S905X-CC (Le Potato) running the ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc.img.xz image.

Is it possible to change the parameters in the /etc/default/grub file & have them take effect? Specifically, I’m trying to change the GRUB_TIMEOUT parameter.

I’ve done all the “normal” stuff:

sudo nano /etc/default grub
sudo update-grub

but that doesn’t seem to work.

I’ve seen some forum posts about needing to update the EFI partition, but I haven’t figured that out either.

It also seems that a USB keyboard has no effect during the GRUB boot/menu. I’ve seen in a couple of forums where others have reported this, but haven’t been able to find a solution.

Otherwise, 22.04 is running fine for my purposes of using my Le Potato as a Pi-hole server.

Ubuntu 22.04 introduced a /etc/default/grub.d. The server uses cloud-init so some timeouts are set there. You can edit those directly to change the timeout since they have higher priority than /etc/default/grub.

I have three of the Le Potato boards. I’m using the latest image (dated 2022-Aug-21): https://distro.libre.computer/ci/ubuntu/22.04/ubuntu-22.04.1-preinstalled-desktop-arm64%2Baml-s905x-cc.img.xz

The bottom left USB port seems inoperative. I get nothing in the kernel messages when I plug anything into it. I’ve also tried Armbian, with the same result. This is consistent on all of the boards, so I have no good reason to believe that this is a hardware problem. All the other USB ports are functional.

What’s needed to get this USB port functional? To be clear, with the board oriented so that the ports are on the top and when looking towards the ports, “bottom left” is the bottom-most USB port next to the ethernet jack.

Check your board to see if the GL852G USB hub chip says GL852G-60. If it does, setup a replacement by emailing cs@loverpi.com with your name, phone, and address. It will be replaced free of charge with handling. This hub IC only works after a GPIO reset or when the board is booted from OTG (different power sequence) so it went through QC without raising any flags regrettably.

Hmm…a correction to my previous statement. It fails on 2 out of the 3. I could swear I tried it on all 3 boards. It may be that I was using a prior kernel image on the third. I acquired the third (working) board a bit later, so I might have simply assumed that it was failing the same way. Sorry about that.

All of the chips say GL852G. No “-60”. However, the 2 that fail also say “KLA0160” on the line underneath the “GL852G” designator.

Is that an alternate designation of the same defective chip?

It’s not a defective chip per-se but rather the newer GL852G KLA0160 hub IC behavior is different than the original GL852G despite having the same label. Genesys Logic really should not have named it GL852G at all.

If you power the board through the USB 5V first (like an external powered hard drive), the hub IC behaves as normal. If you power it via MicroUSB, then the SoC turns on the USB 5V regulator, that bottom left port doesn’t register. That’s how it managed to pass our manufacturing QC tests.

If your application requires that USB port, just send the distributor a message and they will replace it and cover any shipping and handling costs.

1 Like

Cool, thanks. I’ve emailed cs@loverpi.com about it.

1 Like

I just bought my Le Potato board and shifted from Raspberry Pi.
What is the difference between these 2 images?

Which one should I be using and what does the other image fo?

One is for AML-S805X-AC La Frite.
One is for AML-S905X-CC-V2 which is not launched yet. It drops some features and adds some features.

Use ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc.img.xz and NOT Use ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc-v2.img.xz

Hi, i tried installing “cifs-utils” so that I can access some windows shared folders on my network, but it wasn’t working with this error:

mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

After some research, i realised that this error usually arises from the kernel not supporting this. Given that the OS is provided through here, I am hesitant to change the kernel myself in fear of breaking something. Can I check if anyone can help with this?