Ubuntu 22.04 Jammy LTS for Libre Computer Boards

What do you mean there’s no desktop version? There is.

Hi, i recently purchased 2 905x-cc boards. I can boot into either raspbian or Ubuntu, but when I try to connect to network or do any I/O, the boards crash. I’m using a Samsung microSD card for storage right now. Any thoughts?


Power supply is the likely culprit. What are you powering it with?

I’ve plugged into a USB hub that’s plugged into the wall, something that you would charge phones from.

Does the red LED blink at all? Troubleshooting Boot Issues on Libre Computer AML-S905X-CC

USB hubs usually provide 500mA per port. What model do you have?

It boots. I can login and open a terminal, etc. but when I put any load, it will crash. I will check the USB hub and try another power source.

Crash as in reboot spontaneously or crash as in a message? If it reboots spontaneously, it’s definitely a power problem.

The screen goes a solid color, usually green or purplish. I have to pull power to get it to reboot.

That can be a number of things but check with a different power source first.

My 512MB RAM La Frite already installed the latest firmware and ubuntu 20.04.5. everything boot fine, but new I cannot login the service of the ubuntu OS. I tried several possible username and password, still no good luck, anyone can help?

Read the release notes.

I’m stuck in an endless boot loop. I’ve managed to see the UBUNTU wallpaper once, it just keeps loading up until network dispatch service manager and then it reboots. Yes, I have an active ethernet connected (although I believe an internet connection should not be required)

Spontaneous reboots mean insufficient power.

i am trying to first time login to ubnutu-22.04.1-preinstallled-server-arm64-aml-s905x-cc.img and i enter ubuntu and password ubuntu. It then requires me to change my password. I set a new password but instead of asking me to confirm it, I just get returned to the login promt and try to login again and same results

You need to type ubuntu 3 times. Please read the prompt carefully.

Thank you, I see it was asking for the current password again. Can;t believe I missed that.

next issue when I run nmcli dev status
my two interface eth0 and lo both show state disconnected connection –
I have been trying everything online i can find and nothing works.
can you tell me how I can get managed so my connection will show them connected.

on the plus side I have learned a bunch of new stuff today.

I appreciate all your help so far.

What do you have the board connected to? Le Potato does not have Auto MDIX so if you are plugging it into another Fast Ethernet device, you need a standard or crossover cable.

Thank you, that did. eth0 now shows managed and connected. It has been a while since I had to use a cross over cable lol

I’m having issues with the network connection with the s805x image on La Frite. I get the following:
meson8b-dwmac c9410000.ethernet eth0: Reset adapter

I realized that bug was reported on august 2022… is there any update on that? Thanks!