Ubuntu 22.04 Jammy LTS for Libre Computer Boards

Did you select boot from USB from the old firmware?

No such option appears, it just tries different mediums automatically, starting from emmc to usb to tftp (not in that exact order). I need to press esc to cancel and drop to a shell.

When you plug the flashed flash drive into a computer, do you see boot.scr file? If not, you need to reflash the aml-s805x-ac-spiflash file on the USB drive.

Ok, I flashed an 8GB drive with the image file in the tutorial, then I could see that it created a partition that had a boot.scr and a u-boot.bin file. I put it on the board and it picked it up right to the point where “Flash completed” was displayed.

I turned it off then I plugged the usb with the ubuntu image and turned it on, but now I don’t have HDMI output :smiling_face_with_tear: I am going to plug an ethernet cable to see if it actually boots.

I flashed the firmware with

dd if=aml-s805x-ac-spiflash of=/dev/sdc bs=1M status=progress```

The Ubuntu image is 22.04 or 19.04? The latest firmware probably don’t work with the old images since the kernel on the old images are out of date.

The ubuntu image is 22.04, I downloaded it from distro.libre.computer. Also, when I mention I no longer have hdmi, I mean the screen doesn’t display anything when I turn on the board.

Just tested a board here with both firmwares and HDMI definitely works on both for 22.04.

Finally had the chance to try this, it works–thanks. If an update comes, will that require reflashing, or can it be pushed via deb or something?

Only the bootloader isn’t pushed by the debs. You don’t have to re-flash. The bootloader can be flashed by an functionality update to the the libretech-flash-tool we will introduce in the future.

New tools are introduced via debs as well like the libretech-gpio and libretech-ldto. Newer images just include them but you can still apt get them to install on older images.


Sounds great! Looking fwd!

Anything issues to report about kernel 6.0 and the le potato? The update happened yesterday, but I’m not at the install location and won’t be back there for a bit so I’m reticent to actually go ahead and blindly reboot.

The images are already using Linux 6.0.7. If you want to stick to Linux 5.19, install linux-image-lc-5.19-ARCH and remove linux-image-lc-stable-ARCH.

1 Like

Nah, just needed to hear that in fact there were no known issues as yet, thanks.

Hi, maybe this has been addressed already, but I don’t see anything after a quick search.

Main issue: blank screen during boot on La Frite, but the computer itself still works.

I have a La Frite. After updating to the latest firmware, I tried using the 22.04 base version and was met with a blank screen partway through booting. Strange.

Even so, I plugged the Frite into ethernet and it showed up on my router. Strange…

Then I wiped the USB drive and installed 22.04 server. I got the Frite connected to WiFi using the first-boot network-config file. The screen went blank partway through the boot process again. Even with no screen, I managed to get openssh-server installed by just typing in the right stuff (login info, apt update, etc.) To my surprise, I was able to ssh into the Frite after installing the ssh-server.

So… yeah, pretty strange. The computer works but the screen cuts out at some point during boot. I don’t exactly know where. I could try find out more details unless this is already a known issue.


Can you provide more information on this thread: AML GXL No Video on Monitor

1 Like

I have imaged my AML-S905X-CC with ‘ubuntu-22.04.1-preinstalled-server-arm64+aml-s905x-cc.img’.
I have developed a couple of packages, including a service that I would like to include as part of the image. (this would allow me to image a board with preset configurations). where can I find the image source and instructions on how to build a custom .img ?

There’s a couple of options.

  1. If you are using the server images, you can use cloud-init to handle package installs once the device comes online. This requires a network connection.
  2. We have a image prep tool called libretech-image-finalizer-tool that is under development that can take a disk dump and minimize it for re-deployment.

I’m not able to login after inserting the image disk. I get the screen to enter the user name and password but it always tells me its incorrect. I’m using ubuntu ubuntu, and I wait at least a minute before attempting the login. I’ve tried re-flashing the image 3 times and I’ve use a couple different 32GB SanDisks. I’ve gotten Armbian to work but I really want to use Ubuntu which I’m already familiar with. Any Suggestions of something to try to get past this login issue? Thanks!

Are you using the base image or the server image?

The base image username and password are root/root per the release notes.
The server image username and password is ubuntu/ubuntu after cloud-init finishes. However, this might take a minute or two after bootup especially if the MicroSD card is slow.

I mistakenly got the base version which isn’t what I want. I’ll try server . I guess there isn’t a desktop image available, at least I don’t see one. Thanks!