How to install Home Assistant (supervised or HA OS) in Le Potato 2023?

With so many restrictions that exist to install HA on another board outside of those exclusive to HA such as RPI.

I have tried to install HA in many ways, with (armbian, ubuntu Server, Raspbian compiled for potato.). All without success, I already find myself with the need to obtain an answer here for a linux beginner, or I will end up buying an RPI.

I already have two RPIs running with HA (Supervised). and they work well, I just wanted to try le potato to see how viable it was.

Normally I get the incompatibility warning, I have used BYPASS to bypass that but then I get an error in the dependencies in dpkg

I clarify that I have managed to install docker

We will create a guide for this. What have you tried and what error do you get?

[warn] If you want more control over your own system, run
[warn] Home Assistant as a VM or run Home Assistant Core
[warn] via a Docker container.
[warn] ModemManager service is enabled. This might cause issue when using serial devices.
Leaving 'diversion of /etc/NetworkManager/NetworkManager.conf to /etc/NetworkManager/NetworkManager.conf.real by homeassistant-supervised'
Leaving 'diversion of /etc/NetworkManager/system-connections/default to /etc/NetworkManager/system-connections/default.real by homeassistant-supervised'
Leaving 'diversion of /etc/docker/daemon.json to /etc/docker/daemon.json.real by homeassistant-supervised'
Leaving 'diversion of /etc/network/interfaces to /etc/network/interfaces.real by homeassistant-supervised'
Unpacking homeassistant-supervised (1.5.0) over (1.5.0) ...
dpkg: dependency problems prevent configuration of homeassistant-supervised:
 homeassistant-supervised depends on systemd-resolved; however:
  Package systemd-resolved is not installed.

dpkg: error processing package homeassistant-supervised (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

Right now throws that in full installation, when entering the installation command

sudo dpkg -i homeassistant-supervised.deb

Does sudo apt install systemd-resolved not fix it? Which OS image are you using?

Raspbian compiled by you. I have seen that installing “Debian 12 without modification”, the installation works

“sudo apt install systemd” not solved.

Please read our post carefully. It is systemd-resolved, not systemd.

E: Unable to locate package systemd-resolved

That’s what I get

sudo dpkg -i --ignore-depends=systemd-resolved ./homeassistant-supervised.deb

using this code worked for me

See how it goes with the tests I will do these days

If you are using Raspbian 11, you need to enable backports. By default, Bullseye distributions use resolveconf and not systemd-resolved. Debian 12 and Ubuntu uses the new stuff. Not sure why HA would put that as a dependency in their package but you should report it to them since Raspbian 11 and Debian 11 both do not have that package.

When I restarted the first time it stopped working, there is a problem in docker.
I will continue looking for a solution, but it does not seem to be a recommended installation.

HA is designed for Ubuntu and Debian 12, not Raspbian.

1 Like

Well, I’ll wait for your installation guide in Le Potato.

Since in Debian 12 , it is giving errors when rebooting the Host.

Be descriptive. Just saying there are errors is not descriptive and we cannot help you.

Right now it shows this and it doesn’t allow me to access through the local IP.

At the time of installation I present error messages and looking for the event log in Docker I found this.

Sep 17 13:32:37 aml-s905x-cc hassio_supervisor[5923]: 23-09-17 09:32:37 INFO (MainThread [supervisor.resolution.fixup] System autofix complete 
Sep 17 13:32:39 aml-s905x-cc hassio_supervisor[5923]: 23-09-17 09:32:39 ERROR (MainThread) [supervisor.homeassistant.core] Home Assistant has crashed! 
Sep 17 13:32:39 aml-s905x-cc hassio_supervisor[5923]: 23-09-17 09:32:39 ERROR (MainThread) [supervisor.homeassistant.core] Watchdog restart of Home Assistant failed! 
Sep 17 13:32:54 aml-s905x-cc hassio_audio[5923]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes inc>

How did you configure the network? It just says you cannot reach Google’s DNS servers

The network was configured on the router with that DNS. This notice also catches my attention just before starting HA …

N: Download is performed unsandboxed as root as file '/root/homeassistant-supervised.deb' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

Case resolved. A clean installation of the Debian 12 system must be performed (it was the one that worked for me in my case).

Google DNS must be removed if you have them configured on the router where the Le Potato will be connected

After updating & upgrading

We must follow the installation steps that tells us:

The installation of the OS-Agent must be “os-agent_1.6.0_linux_aarch64.deb”
During the installation select Raspberry pi 4 (that worked for me)
It takes at least 30 min or more to display the image by local ip:8123

Note: It can give some errors during the installation but will make a few loops and solve the problems.

You should not install another application or tool on docker since HA Supervised, it does not work well afterwards.

After installing and having created the user, it will present you with some bug that you must fix, taking as a guide the links that it presents in the same HA

Unsupported system - CGroup version.
Unsupported system - AppArmor issues.

It is working, you can restart the Host without problem and the network works very well.

1 Like

When will this guide be completed?

How do I remove the Google DNS?

1 Like