Debian 11 Bullseye and 12 Bookworm for Libre Computer Boards


The images are located on our distro server. If you encounter any problems, please review the general troubleshoot guide and reply to the post with your issue related to this image.

  1. Use the image with a suffix that matches your board! eg. +aml-s905x-cc.img.xz
  2. Decompress/extract the xz compressed image file ending in .img.xz with 7-zip.
  3. Write to a MicroSD card with a bit-accurate flashing tool or Raspberry Pi Imager for lite/headless!

These images use the standard upstream bootchain that is familiar for PC Linux users:

  1. Bootloader with EFI
  2. GRUB via EFI
  3. Linux

The default username and password are root and root. You will be prompted to change the password on first login. To setup an non-root user, run the following with USERNAME as the login name:

sudo adduser USERNAME
sudo adduser USERNAME sudo

Base Images

Debian base images provide a basic CLI interface along with software packages that interface with hardware.

Network Configuration

Network is configured via systemd-networkd.

Wired Network

Please note that systemd has moved interface naming to enX instead of ethX in Debian 12. Please use eth for Debian 11 and en for Debian 12.

Create the following file in /etc/systemd/network/

/etc/systemd/network$ cat 


Wireless Network
Create the following file in



This only handles ARP and IP layers. You still need to handle wireless authentication. You can use either iwd or wpasupplicant. IWD supports WPA3 where as wpa_supplicant only supports WPA3 in Debian 12.

IWD - Recommended

# find the interface name, usually wlx followed by the MAC address
ip link show

# enable IWD
sudo systemctl enable iwd
sudo systemctl start iwd

# reload systemd configuration from before
sudo systemctl daemon-reload

# scan and connect to network
sudo iwctl station INTERFACE_NAME scan # replace INTERFACE_NAME
sudo iwctl station INTERFACE_NAME get-networks #optional, shows network and signal quality
sudo iwctl station INTERFACE_NAME connect SSID # replace SSID with the network name
# you will be prompted for the network password



Succesfully installed Debian Bullseye using this: AML-S905X-CC (Le Potato) SD card images

I’ll write a guide about installing Home Assistant on Le Potato, if anyone is interested. Including all the missing packages, because “this version contains just the minimal amount of software to install the base system and fetch the remaining packages over the Internet”.


Somehow I did download an Debian stretch image frome here somewhere? But now only this entry remain? Weird. I tried this minimal image, but it is not sufficent for my useage needs. There is no dbus, no audio drivers no hdmi drivers, nothing. For a server this would be ok, but not for my needs (network device that transfers audio to HDMI) The images in my database are:

Where did they go? Where to find updates? I would like to go to the new kernel…

This is because the current image causes HDMI to stutter for 0,5 secs every 8 seconds? I have read somewhere, this issue is resolved in Debian Bullseye. But searching here results in this dead end… Did you all drop Debian support? I do not understand this, since Debian stands for free software, as in freedom, and your hardware does too, right?

Those images are old and no longer supported. Raspbian is 99% Debian now so you can use that or the link above until we release Debian formally.

Thanks for the reply. I am not sure, but can Raspbian be used on a headless system? Does Raspbian support the HDMI port for audio only output? The images under the link did not… Do you know when the new Debian will be released?

All of our images including Raspbian definitely supports HDMI audio. Not certain which image you are referring to.

Thanks, I did flash Raspbian (it has kernel 6! wow) to an mSD and HDMI audio works now without any hickups. I am enjoying the improved sound quality right now. Thanks for the tip.

@Alfredo_Diaz_Vazquez were you successful in installing Home Assistant with a supervised approach? I have a renegade and getting stuck at the last steps.

Update: Gave up on supervised approach. Using docker container worked smoothly.

1 Like

I need a working full-featured web server, and lots of experience with Raspis suggests Apache2. Never a problem installing a full LAMP stack there. I’m an experienced webster, and need the whole stack to do my home control weather station work.
With Rasbian 11 (Bullseye? all the names confuse) I was able (I think) to install the whole stack – always crashed with Armbian – but now, FRUSTRATION and too simple: I CANNOT ACCESS /var/www/html. ls (unix list command) shows me brain-dead Windows/Apple style folders, “Bookshelf”, “Public” and my FTP shows me the underlying folders, but doesn’t give me permission to FTP files, change names. Apache2 is working (in /var/www/html) – I can see it there. Pretty sure this is not a LePot problem, but a “security improvement” from Raspi. I am not a Unix wonk, and this has me ready to blow off the Potato. Can anyone help? Does anyone know the su username and password for Bulls-whatever?


I’m new to Libre Computer and looking to build a portable desktop with my Renegade (ROC-RK3328-CC). Debian Bullseye w/ GNOME as DE is my objective, though I intend to test other distros.

My question is: do I need a custom Debian image to install it on a Libre Computer? Can I use Debian’s official images to perform the installation?

I would like to have my OS as free as possible from customizations, and using Debian’s official images would be a huge gain in terms of security.


There is a guide on YouTube on installing Debian from official sources. However, the Linux version Debian is using is old and does not support some features.

1 Like

Hi,did you complete that guide on installing all the missing packages? Would be nice to try. I am looking to make a fully working Debian server that utilizes all the hardware correctly from the Potato board, but so far no success…

Following this post. I too am interested to know if the HA_OS can run as clean as the raspien image is designed.

are you having trouble because of your user? that’s what it sounds like to me. Is this going to be a dev box or a production system?

create a user using the adduser command. then add that user to the sudo group doing a usermod -aG sudo newuser. then edit your sudo file adding the user to the last line and choose how much god powers you want that user to have.

then you can reboot, login using your new user (sudo -u newuser), do an apt install apache2 or nginx and you should be on your way.

I tried downloading Debain 11 from their website, using balena to flash it to as sd card but am having issues with le potato not booting up. Any help would be much appreciated - thanks

You shouldn’t be using balena to flash the sd card. See: Recommended Bit Accurate Flashing Tools

Thank you for the Bookworm image and continued support! I dd’d Armbian and some other images and there were random issues but yours worked like a charm!

EDIT: I spoke to soon. As soon as I rebooted after first boot up I was reminded why I earlier had been looking for other distros. The network is not working and the screen is filled with information about end0 IPv6 link becomes ready, configuring for ply/rmii link mode and etc etc. This goes on and on.

Update your firmware to the latest: AML-S805X-AC La Frite How to Update Board Firmware