Ubuntu 22.04 Jammy LTS for Libre Computer Boards

Thank you, that did. eth0 now shows managed and connected. It has been a while since I had to use a cross over cable lol

I’m having issues with the network connection with the s805x image on La Frite. I get the following:
meson8b-dwmac c9410000.ethernet eth0: Reset adapter

I realized that bug was reported on august 2022… is there any update on that? Thanks!

nevermind… I just realize that the solution was already answered in august 2022… I need a coffee I think :stuck_out_tongue:

I’m having issues with the Ubuntu 20.04.5 image for AML-S905X-CC. After inputing the name and password I get a ‘Authentication Token Manipulation Error’ after typing in the new password. It then resets the login prompt asking for name and password.
Tried both the server and base versions of the image, same issue.
It also looks like the Linux kernel being used is 6.0; is there an image that has an older linux kernel?

Read the prompts carefully. You need to type the password three times.

Wow…yes, I can’t believe I’m that bad at reading… thank you…

In regards to my other question, the current images are with Linux kernel 6.0.
I saw in the Linux Kernel Policy (Linux Kernel Policy) that there are other suppported kernel packages. How would I go about applying one of these? Say kernel 5.10.

Networking does not appear to work after upgrading to kernel 6.1.22, both in uboot and in the OS proper, where the interface eth0 simply doesn’t show up, and nor do a couple of USB controllers (one ASIX, one Realtek). This appears to in turn prevent me from logging in, even locally (systemd-resolved never completes successfully, and my username and password are rejected as ‘incorrect’ at the ensuing login screen, though this could be some other configuration issue that I haven’t figured out as yet as this persists later–I maybe have inadvertently locked down too hard). My keyboard for some reason could not navigate through grub, but after removing the SD and editing the grub cfg so that kernel 6.0.19 boots instead, eth0 shows up again, the system works normally, and I can login via ssh. systemd-resolved still takes quite a while to start, so I probably do still need to fix some configuration related to that, but that should not preclude eth0 from detection altogether, right?
Has anybody else experienced this?

It could be that your bootloader is too old as there was an update to how ethernet MDIO was handled.

  1. Try flashing the bootsector again with libretech-flash-tool to fix ethernet.
  2. USB should not have any changes between 6.0 and 6.1.
1 Like

Probably a stupid question, but is it safe to run the flashtool directly on booted system (with the target being the SD card that the booted system is running off of, I mean)?

Yes, it is completely safe. libretech-flash-tool disables flashing the boot device unless you use the “force” parameter.

1 Like

I finally returned to the premises yesterday and tried the tool–it did in fact resolve my issues. One quick note, if you are flashing on the device itself, most likely your root device will be named “mmcblk1”. Using the force parameter just involves appending ‘force’ to the end of the flash command, which is otherwise the same as written in the readme.

Force enables it to write to devices that are otherwise blocked for safety.


I will be installing the server version on a AML-S905X-CC this weekend. I purchased a heatsink with the board. You say that you recommend a heatsink with the desktop version. Is a heatsink totally unnecessary for the server version? I will be installing it into a Raspberry Pi 3 case that has a fan.

The reason I ask is that I’m planning another project using the desktop version, so I could save the heatsink for it, if it is not needed for the server project, or buy a second one if it is.

I’d use one personally, but you can test to see if you need it. You can monitor heat with cat /sys/class/thermal/thermal_zone0/temp. Divide by 1000 for degrees Celsius. By default you start getting throttled at 60℃.

More on heat here:

1 Like

Thanks angus. I probably can get away without the heatsink because this board will be idle most of the time, but just to be on the safe side, I’ll use it since I have it. The fan will probably be fine at 3V too.

Seems to be affected by this issue

systemd-hostnamed kills wireless connection on incoming connection to apache2 from wan.

Compilation options & dbus implicated in above.

This is an Ubuntu bug. Please report it to them and it will be fixed if they release a fix.

Hi librecomputer, Thanks for building a great Raspberry Pi alternative! I just received my 4gb Renegade board today and have already gotten the Ubuntu desktop up and running successfully. I was even able to use my Edimax N150 Wifi adapter without issue. I intend to use this computer as a means for my tech-challenged mother to watch YouTube and Twitch videos on her TV. I am finding that even in it’s current form it is mostly usable for this purpose. However, I have been unable to get Chromium to use the GPU for rendering videos, which would significantly improve the playback, and thus her experience. I read a comment on your “In-Depth Technical Overview” YouTube video that indicated that this was more of a browser issue than a Linux issue, and is therefore not something you have much control over. With all that in mind, I would like to ask you if there is anything I can do as a user to potentially work around the issue, improve the playback, or at least star the relevant bug on the chromium project website. I am using a heatsink and fan, which seems to help somewhat. Is there anything else I could try in the meantime? I wouldn’t mind using an older version of Chromium while the problem is worked on, but I don’t know how/where to find such a version. I have also tried installing v4l2loopback-dkms which didn’t seem to have any effect. I also remember from your technical overview video that you mentioned something about adding this functionality into an open-source software stack somewhere, but I was left wondering what, (if anything), you installed to make it work in the browser. I also tried fiddling with the command used to run Chromium and some browser flags to no avail. Anyhow, any other help/advice would be greatly appreciated. Thanks,

This should be enabled in Chromium 110 but we have not had the bandwidth to test it yet. We are looking to release updated images by the end of the month with lots of updates and we will test this path.

Thanks for the update librecomputer! With that in mind, I’ll work on other aspects of the project while I wait for the new images and perhaps see if I can get Chromium 110 to work. I’ll post anything interesting that I discover. Thanks,